Bug #9532 Toolkit does not accept newer versions of Java runtime
Submitted: 31 Mar 2005 16:50 Modified: 26 Apr 2005 18:48
Reporter: Justin Hull Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Migration Toolkit Severity:S2 (Serious)
Version:Alpha OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any

[31 Mar 2005 16:50] Justin Hull
Description:
I have java runtime 1.5 installed on my system.  When I run the Toolkit, on the first page I get an error stating the the java RTE 1.4.2 is not installed.  Actually, I have JRE 1.5 installed.

This later propagates to the connection string since my system has the jdbcodbc libary and not the jdbc library.  At this point I cannot use this program to proform a migration.

How to repeat:
Run the program with JRE 1.5 set up on a workstation (JRE 1.4.2 cannot have been installed before).

Suggested fix:
Allow for 1.4.2 versions and above.  Test for JRE versions and use the appropiate jdbc library.
[12 Apr 2005 0:17] Tom Gregory
Hi,

I had the same problem.

I Uninstalled JRE 1.5 
That seems to have fixed it. Now atleast it runs. Although now I have a new error.

A friend of mine, who is a Java developer told me sometimes people write their software for a specific runtime. He keeps many different versions on hand.

TomG.
mosh1120@hotmail.com
[24 Apr 2005 11:28] Roman Widmer
Exactly the same problemon my system. Started with JRE Version 1.4.2.
[26 Apr 2005 18:48] Michael G. Zinner
Thank you for your bug report. This issue has already been fixed
in the latest released version of that product, which you can download at 
http://www.mysql.com/downloads/
[17 Jun 2005 11:06] Ivan Cherkasov
Hello.
Just downloaded from this link. Bug persists :(
Look at http://forums.mysql.com/read.php?104,30226