Bug #95071 mysqld fails to start
Submitted: 20 Apr 17:06 Modified: 9 May 15:02
Reporter: Robb Allan Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:8.0.15 OS:FreeBSD (12.0)
Assigned to: Bogdan Kecman CPU Architecture:Any

[20 Apr 17:06] Robb Allan
Description:
mysqld silently fails to start.

log entry:

2019-04-20T04:51:21.765851Z 1 [ERROR] [MY-012097] [InnoDB] Table flags are 0x4800 in the data dictionary but the flags in file mysql.ibd  are 0x800!
2019-04-20T04:51:21.765897Z 1 [ERROR] [MY-013183] [InnoDB] Assertion failure: fil0fil.cc:2370 thread 34430127616
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/8.0/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
04:51:21 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
Attempting to collect some information that could help diagnose the problem.
As this is a crash and something is definitely wrong, the information
collection process might fail.

key_buffer_size=268435456
read_buffer_size=131072
max_used_connections=0
max_threads=151
thread_count=1
connection_count=0
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 321742 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x804347000
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7fffdfdfcf40 thread_stack 0x46000
0x2c4066e <_Z19my_print_stacktracePhm+0x2e> at /usr/local/libexec/mysqld
0x202f452 <handle_fatal_signal+0x2c2> at /usr/local/libexec/mysqld
0x803d0d4b6 <_pthread_sigmask+0x536> at /lib/libthr.so.3

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (0): is an invalid pointer
Connection ID (thread ID): 1
Status: NOT_KILLED

How to repeat:
re-start, same result.
[21 Apr 16:26] Terje Røsten
Thanks for your report!

Is this on a fresh datadir created with MySQL 8.0.15 or is this upgrade from previous release?
[28 Apr 11:25] Robb Allan
An upgrade. Have since uninstalled, reinstalled, and receive same error.
[9 May 15:02] Bogdan Kecman
Hi,

Are you saying that you did a clean install of 8.0.16 and that it won't start on FreeBSD as I'm not able to reproduce this.

thanks