Bug #94798 Since MySQL 8.0.15 execution plan has changed in a bad way
Submitted: 27 Mar 2019 12:55 Modified: 6 May 2019 13:08
Reporter: DD DDD Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Optimizer Severity:S5 (Performance)
Version:8.0.12 OS:Linux
Assigned to: CPU Architecture:Any
Tags: performance executionplan

[27 Mar 2019 12:55] DD DDD
Description:
Execution Plan has changed and impact performance really bad.

How to repeat:
See explain query and execution plan in attachment
[27 Mar 2019 12:56] DD DDD
explain queries

Attachment: explains.txt (text/plain), 30.90 KiB.

[27 Mar 2019 12:56] DD DDD
explains for mysql 8.0.11 / 8.0.12 / 8.0.15

Attachment: explains.txt (text/plain), 30.90 KiB.

[5 Apr 2019 12:54] Sinisa Milivojevic
HI,

Thank you for your bug report. 

We do need some additional info from you.

First of all, how did the execution plan change exactly during the lifetime from 8.0.11 to 8.0.15 ???

Which performance was better, that of 8.0.11, 8.0.12 or 8.0.15.

In case that 8.0.15 has fastest execution of the queries, then this is not a bug.

However, if 8.0.15 is SIGNIFICANTLY slower then its predecessors, then we would need the entire repeatable test case. That would include dumps of all tables involved as well as queries that, when executed show a significant decrease of the performance in 8.0.15.

Many thanks in advance.
[6 May 2019 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".