Bug #94304 ERROR 1683 (HY000) when INSERT INTO performance_schema.setup_actors
Submitted: 13 Feb 7:17 Modified: 18 Mar 15:27
Reporter: Trsen Zhang Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Performance Schema Severity:S4 (Feature request)
Version:5.7.24 OS:Red Hat (6.5)
Assigned to: CPU Architecture:x86
Tags: ERROR 1683 (HY000): Invalid performance_schema usage.

[13 Feb 7:17] Trsen Zhang
Description:
mysql>  INSERT INTO performance_schema.setup_actors (HOST,USER,ROLE) VALUES('localhost','joe','%');
ERROR 1683 (HY000): Invalid performance_schema usage.
mysql> DELETE FROM performance_schema.setup_actors;
Query OK, 0 rows affected (0.00 sec)

mysql> 
mysql> 
mysql>  INSERT INTO performance_schema.setup_actors (HOST,USER,ROLE) VALUES('localhost','joe','%');
ERROR 1683 (HY000): Invalid performance_schema usage.
mysql> show grants;
+-----------------------------------------------------------------------------------+
| Grants for root@localhost                                                         |
+-----------------------------------------------------------------------------------+
| GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost' WITH GRANT OPTION               |
| GRANT ALL PRIVILEGES ON `perfromance_schema`.* TO 'root'@'localhost'              |
| GRANT SELECT, UPDATE ON `performance_schema`.`setup_actors` TO 'root'@'localhost' |
| GRANT PROXY ON ''@'' TO 'root'@'localhost' WITH GRANT OPTION                      |
+-----------------------------------------------------------------------------------+
4 rows in set (0.00 sec)

How to repeat:
mysql>  INSERT INTO performance_schema.setup_actors (HOST,USER,ROLE) VALUES('localhost','joe','%');
ERROR 1683 (HY000): Invalid performance_schema usage.
mysql> DELETE FROM performance_schema.setup_actors;
Query OK, 0 rows affected (0.00 sec)

mysql> 
mysql> 
mysql>  INSERT INTO performance_schema.setup_actors (HOST,USER,ROLE) VALUES('localhost','joe','%');
ERROR 1683 (HY000): Invalid performance_schema usage.
mysql> show grants;
[18 Mar 15:27] Sinisa Milivojevic
Hi,

Thank you for your feature request.

However, please do note that P_S is designed so that only MySQL server itself inserts data into P_S tables.

Hence, we can not accept your feature request, since then P_S would make no sense what so ever.

Simply, this is not a valid feature request.