Bug #94181 Can't install MySQL Server on Ubuntu
Submitted: 3 Feb 7:53 Modified: 3 Mar 14:23
Reporter: Lee Chea Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Server: Installing Severity:S2 (Serious)
Version:5.7 OS:Ubuntu
Assigned to: CPU Architecture:Any
Tags: install, permissions, ubuntu

[3 Feb 7:53] Lee Chea
Description:
I was upgrading mysql-server on my computer when it gave me the below error, then I uninstalled mysql-server from my computer and when I tried to install it again with apt-get install it does not fully install. I still this error message.
ERROR: Unable to start MySQL server:
mysqld: Can't read dir of '/etc/mysql/mysql.conf.d/' (Errcode: 13 - Permission denied)
mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
Please take a look at https://wiki.debian.org/Teams/MySQL/FAQ for tips on fixing common upgrade issues.

I look at the file permission for this directory and they are 
drwxr-xr-x 2 root root 4096 Feb  3 02:20 mysql.conf.d

How to repeat:
I upgraded mysql-server to 5.7 with apt-get upgrade.

Error out with the about error message.

Uninstalled mysql-server from computer.

apt-get install mysql-server.

Got the same error message.
[3 Feb 11:05] Terje Røsten
Hi!

This might be AppArmor related, does command 

 dmesg 

list  any issue?
[4 Mar 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".