Bug #94178 process exit when modify column type
Submitted: 2 Feb 8:13 Modified: 15 May 9:17
Reporter: RuiHuan Wang Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S4 (Feature request)
Version:8.0.15 OS:Linux (Fedora release 29 Twenty Nine x86_64)
Assigned to: CPU Architecture:x86
Tags: WBBugReporter

[2 Feb 8:13] RuiHuan Wang
Description:
[wangruihuan@localhost yum.repos.d]$ cat /home/wangruihuan/.mysql/workbench/log/wb.log
16:00:48 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: /usr/share/mysql-workbench
	plugin path: /usr/lib64/mysql-workbench/plugins
	struct path: /usr/share/mysql-workbench/grt
	module path: /usr/lib64/mysql-workbench/modules
	library path: /usr/share/mysql-workbench/libraries
	user data dir: /home/wangruihuan/.mysql/workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
16:00:48 [INF][      WBContext]: WbContext::init
16:00:48 [INF][            WBA]: Looking for extension modules for WBA...
16:00:48 [INF][            WBA]: 0 extension modules found
16:00:48 [WRN][            grt]: /usr/share/mysql-workbench/modules/data/mysql_rdbms_info.xml:1446: link 'om.mysql.rdbms.mysql.driver.native_sshtun' <object > key=owner could not be resolved
16:00:48 [WRN][            grt]: /home/wangruihuan/.mysql/workbench/connections.xml:25: link '52beeae8-26be-11e9-84fb-702c1f2cef14' <object GrtObject> key=owner could not be resolved
16:00:48 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Linux/Unix version 8.0.15 CE build 14271522 (64 bit)
	Configuration Directory: /home/wangruihuan/.mysql/workbench
	Data Directory: /usr/share/mysql-workbench
	Cairo Version: 1.16.0
	OS: Fedora release 29 (Twenty Nine) x86_64
	CPU: 4x Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz (2508.564MHz) - 7.68GiB RAM
No video adapter info available
	Distribution: Fedora release 29 (Twenty Nine)

	Fips mode enabled: no

16:00:51 [INF][SQL Editor Form]: Opened connection 'ali' to (Ubuntu) version 5.7.22-0ubuntu0.16.04.1

How to repeat:
modify column type by mouse click.
[2 Feb 8:17] RuiHuan Wang
the output from terminal

Attachment: err (application/octet-stream, text), 111.56 KiB.

[12 Feb 10:31] RuiHuan Wang
maybe this is useful..

$ mysql-workbench 
Found /lib64/libproj.so.12
Ready.

(mysql-workbench-bin:16253): Gdk-CRITICAL **: 18:24:57.880: gdk_device_get_source: assertion 'GDK_IS_DEVICE (device)' failed
*** Segmentation fault
[15 May 9:17] Miguel Solorzano
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=94757.