Bug #94009 Workbench 8.0.13 randomly hangs/freezes before running a query
Submitted: 22 Jan 2019 22:54 Modified: 4 Mar 2019 17:35
Reporter: Richard Lund Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:8.0.13 OS:Microsoft Windows (8.0)
Assigned to: CPU Architecture:x86 (Intel Code i7 3770K, 32GB RAM)

[22 Jan 2019 22:54] Richard Lund
Description:
One of the admins on the forum asked me to report this (https://forums.mysql.com/read.php?152,672174,672198#msg-672198)

Issue:

When I run any query, it may go through immediately, but more typically the entire Workbench will hang or freeze for anything starting around 10 seconds to the point where Windows believes Workbench is unresponsive. I have not yet found any pattern or common denominator in this.

If the query finishes loading, the log screen below claims the duration of the query was typically around 0.015 seconds or less, so it looks to me as if the issue was not in communicating with my Ubuntu server. Also, the web project I am working on has not once taken longer than an instant to query any number of database results.

I typically use three ways to run queries, and all produce the same general issue although the visuals may be slightly different:

1. Schemas box - I use one of the icons to either see the table structure or load the table content.

2. Query box - I use the lightning icon to execute the query. If I do that and the system hangs, there will be a spinning circle in the tab of the query I am working in.

3. Apply - inside the Query box, after I have made changes, when I click the Apply button in the lower right corner, it will typically display the query and let me press the next Apply button, but the screen where it says "Execute SQL Statements" will then hang.

The issue SEEMS to start happening after I have not used the Workbench for a few minutes. It could be some form of connection timeout to my server, but again once the query actually is sent, the results come back almost immediately, so I am more apt to believe there is an issue with Workbench going on.

This is severely affecting my developing, so I hope someone will be able to help me.

System description:

Windows 8 is running VMWare Workstation 14 Player with a VM running Ubuntu 16.04.4 LTS 64bit only the server part, no Desktop. I used most of the default settings when setting up my Apache/PHP/MySQL server as this is only my development server.

My computer has 32GB of RAM, and I allocated 1GB to Ubuntu.

MySQL Workbench 8 is running on the same Windows 8 computer.

How to repeat:
Unknown since the issue does not appear all the time.

Typically, if I come back to Workbench after having written code for a few minutes, it will act up as described. Sometimes it will continue to hang, sometimes (like right now as I am writing this) the query will go through immediately.

To be honest, I have dealt with this for days now, and now as I am reporting it, the system is working better than it has all week...

Suggested fix:
Either I have come across a bug in Workbench, or maybe some library that it depends on may have been changed. I run games on this computer which often install various library updates (dot net, etc.).

Other than that I have no idea what it could be. I don't have any other program that behaves this way.
[4 Feb 2019 17:35] Miguel Solorzano
Thank you for the bug report. Please test version 8.0.15. Thanks.
[5 Mar 2019 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".