Bug #93960 Can not connect to databases, bad handshake
Submitted: 17 Jan 10:34 Modified: 17 Jan 11:24
Reporter: Gerben Bokma Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:8.0.13 OS:Microsoft Windows (Microsoft Windows 10 Pro)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[17 Jan 10:34] Gerben Bokma
Description:
I use MySQL Workbench many years. I upgraded MySQL Workbench from 6.3.10 to 8.0.13. 
With the new version I was only able to reach MySQL databases on localhost! All other MySQL databases (a few dozen) based on an IP address and port 3306 were no longer available. When testing the connection comes the message "Bad handshake". I am very disappointed in this product, I had expected a better test of this version, also to older database versions. Many production databases still run on older versions that you also need to reach with a newer MySQL Workbench.

How to repeat:
Upgrade MySQL Workbench from 6.x to 8.0.13. and try to reach an older MySQL database running on version 5.1.

Suggested fix:
Do not forget the older versions that have made MySQL great! If necessary, with an option to also reach those older MySQL servers.
[17 Jan 11:24] Umesh Shastry
Hello Gerben,

Thank you for the report.
Imho this is duplicate of Bug #91828, please see Bug #91828

[31 Jul 2018 7:05] Mike Lischke
Server 5.1 is not a supported MySQL version for Workbench. Supported versions are 5.5, 5.6, 5.7 and 8.0.

regards,
Umesh