Bug #93939 Solved
Submitted: 15 Jan 14:06 Modified: 16 Jan 8:44
Reporter: Roy Assis Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8/0 OS:Microsoft Windows (8.1)
Assigned to: CPU Architecture:Any
Tags: encoding, hebrew

[15 Jan 14:06] Roy Assis
Description:
Hey 

I'm new to MySQL and with SQL in general. 
I'm working with MySQL workbench and i"m trying to import a CSV file containing Hebrew characters to MySQL . 

When trying to use the import wizard, I get an error: 

--------------
Table Data Import
Can't analyze file. Please try to change encoding type. 
If that doesn't help, maybe the file is not: csv, or the 
file is empty.
---------------

I am able thou to change the encoding via the import wizard to" latin2, latin1 or cp1250. This disables the error, but then my Hebrew characters are showed as gibberish. 

Waiting for your reply and thank you 
Roy

How to repeat:
use this csv 

name,שם,גיל,מזהה
roy,רועי,12,1
shalom,שלמה,13,2
shmolik,שמוליק,14,3
eitan,איתן,15,4

Suggested fix:
Don't know. 
Tried importing with the latin encoding and then change the encoding of the table using commands. That doesn't.
[15 Jan 14:07] Roy Assis
excel generated CSV file containing Hebrew chars

Attachment: hebrew.csv (application/vnd.ms-excel, text), 89 bytes.

[15 Jan 16:41] Miguel Solorzano
Thank you for the bug report.
[16 Jan 6:44] Roy Assis
Ok solved the issue. The encoding of the excel CSV was not UTF8. 
Excel gives you the option to select the encoding, but as I read on some comment on stackoverflow that I can't find right now, excel ignores it. 

Using an online CSV converter solved the issue.