Bug #93884 why not remove instance from innodb cluster?
Submitted: 11 Jan 2:19 Modified: 22 Jan 12:05
Reporter: yingzhe shi Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Shell AdminAPI InnoDB Cluster Severity:S3 (Non-critical)
Version:Ver 8.0.13 OS:CentOS (CentOS Linux release 7.6.1810 (Core))
Assigned to: Bogdan Kecman CPU Architecture:x86

[11 Jan 2:19] yingzhe shi
Description:
I have an existing deployment of Group Replication with three node4, and I use the adoptFromGR option to the dba.createCluster() function. After creating innodb cluster, I add a new node to the innodb cluster. I use <cluster>.removeInstance() to remove the node, but failed. 
error_msg: SystemError: LogicError: Cluster.remove_instance: get_string(7): field is NULL

How to repeat:
1. Create MGR cluster
2. use adoptFromGR option to the dba.createCluster() function.
3. add a new node to the innodb cluster
4. removeInstance
[22 Jan 12:05] Bogdan Kecman
Hi,

> <cluster>.removeInstance() to remove the node, but failed. 
> error_msg: SystemError: LogicError: Cluster.remove_instance: get_string(7): field is NULL

I cannot reproduce this. What parameter did you give to removeInstance? 

Please share more data.

all best
Bogdan