Bug #9385 states wrong data type for datetime as text in MS Access
Submitted: 24 Mar 2005 16:22 Modified: 4 Apr 2005 20:55
Reporter: Rajiv Sharma Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:3.51.11-1 OS:Microsoft Windows (Windows 2000)
Assigned to: CPU Architecture:Any

[24 Mar 2005 16:22] Rajiv Sharma
Description:
I have installed MyODBC-3.51.11-1-win.exe on a fresh install of Windows 2000 and all critical updates and service packs, and this version takes datetime fields from the db, but MS Access recognizes them text fields.

Luckly at the office we have a copy of MyODBC-3.51.06.exe and that works fine. 

Our mysql version is 3.23.58-Max-log on a linux server.

How to repeat:
Remove any previous mysql obdcs and install MyODBC-3.51.11-1-win.exe.
Create a new database in MS Access . 
Link to a MySQL table using the Link manager, where the table has a datetime field. (Apparently this may happen on date and timestamp data types as well.)

Then unde the tables tab in Access select the table and click on design. All the time related data typed fields will be represented as 'text'.

Suggested fix:
For the mysql programmers, use the logic from MyODBC-3.51.06.exe because this one works.

From a user's point of view, unistall all mysql obdcs and install version 3.51.06 and then the time retalated data types  will work.
[24 Mar 2005 22:27] Miguel Solorzano
I tested with Access 2003 and only found the issue when a datetime
column exists, only date and timestamp not presents this issue.
[28 Mar 2005 16:43] Rajiv Sharma
I have been using Access 2000. I also have confirmed the datetime data type only. However when I was researching this issue I did stumble on the last comment at 
http://dev.mysql.com/doc/mysql/en/msaccess-setup.html.

However, I haven't verified it, but you may want to test it on Access 2000.

Thanks for looking into this!
[28 Mar 2005 18:26] Steve Gofarmer
Hello Rajiv !
The problem is discribed as Bug#8363 - 3.51.11 icorrectly describes date field
So if you wanna know how to fix goto http://bugs.mysql.com/bug.php?id=9385
[28 Mar 2005 18:27] Steve Gofarmer
sorry finger-troubles at copy &paste - correct link is

http://bugs.mysql.com/bug.php?id=8363