Bug #93774 Poor Usability with OSX Dark Mode
Submitted: 2 Jan 4:19 Modified: 2 Jan 5:07
Reporter: Joseph Gold Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.13 OS:Mac OS X (10.14.2)
Assigned to: CPU Architecture:Any
Tags: dark, Dark Mode, Dark Theme, os x, theme

[2 Jan 4:19] Joseph Gold
Description:
When using OS X Mojave's Dark Mode, MySQL Workbench is unusable, due to white text being displayed on a white background, and similar issues throughout the app. It seems that certain UI elements have hardcoded colors, rather than using system colors.

How to repeat:
Enable Dark Mode, then open MySQL Workbench.

Suggested fix:
Take a look at how you are setting colors in the app.
[2 Jan 4:21] Joseph Gold
Example of unreadable text.

Attachment: Screen Shot 2019-01-01 at 11.21.12 PM.png (image/png, text), 866.35 KiB.

[2 Jan 4:25] Joseph Gold
EER Diagram

Attachment: Screen Shot 2019-01-01 at 11.24.59 PM.png (image/png, text), 815.21 KiB.

[2 Jan 5:07] Umesh Shastry
Hello Joseph,

Thank you for the report.
This is duplicate of Bug #92902, and fixed in upcoming release as per the change log details.

[12 Dec 2018 16:30] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.14 release, and here's the changelog entry:

MySQL Workbench now supports macOS 10.14 Mojave, including full
compatibility with the Dark Mode color scheme.

Thank you for the bug report.

regards,
Umesh