Bug #93739 Can't connect to google SQL server DB through SSL
Submitted: 26 Dec 2018 4:06 Modified: 26 Dec 2018 17:53
Reporter: Nicolas Guffanti Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:8.0.13 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: Google SSL Connection Error

[26 Dec 2018 4:06] Nicolas Guffanti
Description:
I'm getting a "cannot connect to databse server" error message when trying to connect to a google SQL server Database using the SSL certificates.

However, if I have a workbench instance already opened in the db, I can query the db without problems, this means the configuration is correctly set. To get to this state -to properly open a workbench instance-, I have to enable my IP on the Google SQL page and then perform the connection through the workbench.

But when I remove the IP from the allowed configuration (since I want to use SSL) I can no longer connect to the database.

How to repeat:
Download all .pem files from Google SQL site
Configure the hostname, port, user, password and all three .pem files on the SSL tab.
-SOMETIMES- when clicking on TEST CONNECTION I get no message at all, no fail nor success message shows up.
Save configuration and try to connect to the server.
ERROR MESSAGE

Suggested fix:
Try to properly fix the SSL connection with Google SQL Database
[26 Dec 2018 17:53] Nicolas Guffanti
Revoked all the certificates from the server and made further configurations, it is now working, although it seems slower...