Bug #93731 SSH tunnel issue after updating to last version
Submitted: 24 Dec 2018 6:38 Modified: 24 Dec 2018 9:28
Reporter: Denys Pasishnyi Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:8.0.13 OS:Ubuntu (18.04)
Assigned to: CPU Architecture:x86 (Intel i7)

[24 Dec 2018 6:38] Denys Pasishnyi
Description:
After updating Workbench from 6.3.10 to 8.0.13 SSH tunnel stop working. 

How to repeat:
Try to connect to a database via SSH tunnel.
[24 Dec 2018 8:17] Miguel Solorzano
8.0.13

Attachment: 93731_1.png (image/png, text), 123.93 KiB.

[24 Dec 2018 8:19] Miguel Solorzano
ssh connection test

Attachment: 93731_2.png (image/png, text), 119.22 KiB.

[24 Dec 2018 8:21] Miguel Solorzano
Thank you for the bug report. Please prior attached screenshots.
[24 Dec 2018 8:23] Denys Pasishnyi
Error

Attachment: Selection_001.png (image/png, text), 156.27 KiB.

[24 Dec 2018 8:24] Denys Pasishnyi
Workbench version

Attachment: Selection_002.png (image/png, text), 108.39 KiB.

[24 Dec 2018 8:32] Denys Pasishnyi
I can connect to remote server via SSH in terminal but Workbench responds with an error to the same connection without any details.
Could I extract somehow logs or something else to help you debug this error?
[24 Dec 2018 8:35] Denys Pasishnyi
Logs

Attachment: wb.log (text/x-log), 1.59 KiB.

[24 Dec 2018 8:37] Denys Pasishnyi
I checked logs and they say that is the problem is "User authentication failed" but via terminal with same ssh configuration I can connect and today before updating to Workbench 8.0.13 the previous version 6 was working for same connection.
[24 Dec 2018 8:37] Denys Pasishnyi
I checked logs and they say that is the problem is "User authentication failed" but via terminal with same ssh configuration I can connect and today before updating to Workbench 8.0.13 the previous version 6 was working for same connection.
[24 Dec 2018 8:39] Denys Pasishnyi
Just in case, I use this command in terminal `ssh -i /home/denys/.ssh/id_rsa.pub denys@35.178.77.175`
[24 Dec 2018 8:48] Denys Pasishnyi
For ssh connection, I don't need a password. Possibly this is required by last Workbench version
[24 Dec 2018 9:27] Denys Pasishnyi
I found the issue. My ssh connection wasn't requiring password or ssh key. I removed that from Workbench configuration but seems Workbench requires it. After configuring my connection to require password Workbench connected without error.

Workbench should specify that password or ssh key is required for SSH tunnel or return a detailed error.
[24 Dec 2018 9:28] Denys Pasishnyi
Can be close. I'll open another bug related to my previous comment.