Bug #93688 MYSQL DON'T WORKING
Submitted: 19 Dec 2018 17:43 Modified: 10 Jan 16:21
Reporter: Roberto Sanchez de la Rosa Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.0.13 OS:Microsoft Windows (WINDOWS 10 Education)
Assigned to: CPU Architecture:x86 (I7)
Tags: mysql does not start

[19 Dec 2018 17:43] Roberto Sanchez de la Rosa
Description:
When I try to run mysqld --console show this information and it does not start
2018-12-19T17:33:43.287906Z 0 [System] [MY-010116] [Server] c:\mysql8\bin\mysqld.exe (mysqld 8.0.13) starting as process 11372
2018-12-19T17:33:45.679629Z 0 [System] [MY-010229] [Server] Starting crash recovery...
2018-12-19T17:33:45.713991Z 0 [System] [MY-010232] [Server] Crash recovery finished.
2018-12-19T17:33:46.944774Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
17:33:47 UTC - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
Attempting to collect some information that could help diagnose the problem.
As this is a crash and something is definitely wrong, the information
collection process might fail.

key_buffer_size=8388608
read_buffer_size=131072
max_used_connections=0
max_threads=151
thread_count=0
connection_count=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 67684 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x16bc7eb0740
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
7ff7b9ee271b    mysqld.exe!find_acl_user()[sql_auth_cache.cc:930]
7ff7ba1831e7    mysqld.exe!populate_roles_caches()[role_tables.cc:258]
7ff7b9ee65d7    mysqld.exe!reload_roles_cache()[sql_auth_cache.cc:1444]
7ff7b9edda62    mysqld.exe!acl_reload()[sql_auth_cache.cc:2367]
7ff7b9eda65a    mysqld.exe!acl_init()[sql_auth_cache.cc:1521]
7ff7b9e6c310    mysqld.exe!win_main()[mysqld.cc:6352]
7ff7b9e66eb5    mysqld.exe!mysql_service()[mysqld.cc:6695]
7ff7b9e674ce    mysqld.exe!mysqld_main()[mysqld.cc:6911]
7ff7bb19ebdd    mysqld.exe!__scrt_common_main_seh()[exe_common.inl:253]
7ffcca073034    KERNEL32.DLL!BaseThreadInitThunk()
7ffcca1c3691    ntdll.dll!RtlUserThreadStart()

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (0):
Connection ID (thread ID): 0
Status: NOT_KILLED

The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

How to repeat:
I dont know
[19 Dec 2018 18:03] Miguel Solorzano
Thank you for the bug report. That MySQL 8.0.13 is a zip package install?. How you created the mysql data or you are using an older data?. Thanks.
[19 Dec 2018 18:09] Roberto Sanchez de la Rosa
It is a Zip install
I created the data directory with the opciĆ³n install
Mysqld --install
[19 Dec 2018 18:19] Miguel Solorzano
We're sorry, but the bug system is not the appropriate forum for asking help on using MySQL products. Your problem is not the result of a bug.

Support on using our products is available both free in our forums at http://forums.mysql.com/ and for a reasonable fee direct from our skilled support engineers at http://www.mysql.com/support/

https://dev.mysql.com/doc/refman/8.0/en/windows-install-archive.html

Thank you for your interest in MySQL.
[10 Jan 16:21] Roberto Sanchez de la Rosa
Sorry but I disagree with the opinion that this is not a bug.
I think it is a bug about roles 
I rectify about how i created the data directory, I said that I created it with mysqld --install, and I really used mysqld --initialize

Thanks
[10 Jan 18:20] Miguel Solorzano
initialized and started

Attachment: 93688.png (image/png, text), 53.94 KiB.