Bug #93671 Unknown file errors during 8.0.13 release builds
Submitted: 19 Dec 2018 8:35 Modified: 19 Dec 2018 12:26
Reporter: Roel Van de Paar (OCA) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Compiling Severity:S2 (Serious)
Version:8.0.13 OS:Any
Assigned to: CPU Architecture:Any
Tags: Release Build

[19 Dec 2018 8:35] Roel Van de Paar
Description:
8.0.13 build gives various unknown file errors. This seems to happen only for optimized/release builds. 

How to repeat:
Simply compile 8.0.13 optimized
[19 Dec 2018 8:36] Roel Van de Paar
[ 82%] Building CXX object sql/CMakeFiles/sql_main.dir/parse_tree_handler.cc.o
[ 82%] Building CXX object sql/CMakeFiles/sql_main.dir/parse_tree_helpers.cc.o
Scanning dependencies of target http_server
[ 82%] Building CXX object router/src/http/src/CMakeFiles/http_server.dir/http_server_plugin.cc.o
[ 82%] Building CXX object router/tests/CMakeFiles/routertest_helpers.dir/helpers/mysql_session_replayer.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/ext/rapidjson/include.
[ 82%] Building CXX object router/src/http/src/CMakeFiles/http_server.dir/static_files.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/ext/rapidjson/include.
[ 82%] Building CXX object sql/CMakeFiles/sql_main.dir/parse_tree_hints.cc.o
Scanning dependencies of target metadata_cache_static
[ 82%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache_static.dir/src/metadata_factory.cc.o
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/privilege.cc.o
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/row.cc.o
[ 82%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache_static.dir/src/cluster_metadata.cc.o
[ 82%] Building CXX object router/tests/CMakeFiles/routertest_helpers.dir/helpers/router_component_test.cc.o
[ 82%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache_static.dir/src/metadata_cache.cc.o
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/row_group_dump_task.cc.o
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/simple_id_generator.cc.o
Scanning dependencies of target metadata_cache
[ 82%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache.dir/src/metadata_cache_plugin.cc.o
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/single_transaction_connection_provider.cc.o
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/sql_formatter.cc.o
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/sql_formatter_options.cc.o
[ 82%] Building CXX object router/src/http/src/CMakeFiles/http_server.dir/http_server_component.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/ext/rapidjson/include.
[ 82%] Building CXX object router/tests/CMakeFiles/routertest_helpers.dir/helpers/tcp_port_pool.cc.o
[ 82%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache_static.dir/src/cache_api.cc.o
[ 82%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache_static.dir/src/group_replication_metadata.cc.o
[ 82%] Building CXX object sql/CMakeFiles/sql_main.dir/parse_tree_items.cc.o
[ 82%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache.dir/src/plugin_config.cc.o
Scanning dependencies of target metadata_cache_tests
[ 82%] Building CXX object router/src/metadata_cache/tests/CMakeFiles/metadata_cache_tests.dir/__/src/cluster_metadata.cc.o
Scanning dependencies of target mysql_protocol
[ 82%] Building CXX object router/src/mysql_protocol/CMakeFiles/mysql_protocol.dir/src/handshake_packet.cc.o
[ 82%] Building CXX object router/tests/CMakeFiles/routertest_helpers.dir/helpers/script_generator.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/router/include.
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/harness/include.
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/standard_progress_watcher.cc.o
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/standard_writer.cc.o
[ 82%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache.dir/src/metadata_factory.cc.o
[ 82%] Building CXX object router/tests/CMakeFiles/routertest_helpers.dir/helpers/cmd_exec.cc.o
[ 82%] Linking CXX static library libmetadata_cache_static.a
[ 82%] Building CXX object router/src/metadata_cache/tests/CMakeFiles/metadata_cache_tests.dir/__/src/metadata_cache.cc.o
[ 82%] Built target metadata_cache_static
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/stored_procedure.cc.o
[ 82%] Building CXX object sql/CMakeFiles/sql_main.dir/parse_tree_node_base.cc.o
[ 82%] Building CXX object sql/CMakeFiles/sql_main.dir/parse_tree_nodes.cc.o
[ 82%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/table.cc.o
[ 82%] Linking CXX static library libroutertest_helpers.a
[ 82%] Built target routertest_helpers
[ 82%] Building CXX object router/src/mysql_protocol/CMakeFiles/mysql_protocol.dir/src/error_packet.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/router/include.
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/harness/include.
[ 82%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache.dir/src/cluster_metadata.cc.o
[ 82%] Linking CXX shared library ../../../../plugin_output_directory/http_server.so
[ 82%] Built target http_server
[ 84%] Building CXX object router/src/mysql_protocol/CMakeFiles/mysql_protocol.dir/src/base_packet.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/router/include.
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/harness/include.
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/parse_tree_partitions.cc.o
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/select_lex_visitor.cc.o
[ 84%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/table_deferred_indexes_dump_task.cc.o
[ 84%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/table_definition_dump_task.cc.o
Scanning dependencies of target mysql_protocol_static
[ 84%] Building CXX object router/src/mysql_protocol/CMakeFiles/mysql_protocol_static.dir/src/handshake_packet.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/router/include.
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/harness/include.
Scanning dependencies of target test_mysqlrouter_plugin_info_plugin_info_app
[ 84%] Building CXX object router/src/plugin_info/tests/CMakeFiles/test_mysqlrouter_plugin_info_plugin_info_app.dir/test_plugin_info_app.cc.o
[ 84%] Linking CXX shared library ../../../plugin_output_directory/mysql_protocol.so
Unknown file/directory /git/MS-8.0-trunk_opt/src/harness/include.
[ 84%] Building CXX object router/src/metadata_cache/tests/CMakeFiles/metadata_cache_tests.dir/__/src/cache_api.cc.o
[ 84%] Built target mysql_protocol
[ 84%] Building CXX object router/src/metadata_cache/tests/CMakeFiles/metadata_cache_tests.dir/__/src/plugin_config.cc.o
[ 84%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/table_rows_dump_task.cc.o
[ 84%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache.dir/src/metadata_cache.cc.o
[ 84%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache.dir/src/cache_api.cc.o
[ 84%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/tables_definition_ready_dump_task.cc.o
[ 84%] Building CXX object router/src/mysql_protocol/CMakeFiles/mysql_protocol_static.dir/src/error_packet.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/router/include.
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/harness/include.
[ 84%] Building CXX object router/src/mysql_protocol/CMakeFiles/mysql_protocol_static.dir/src/base_packet.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/router/include.
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/mysql_protocol/../src/harness/include.
[ 84%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/thread.cc.o
[19 Dec 2018 8:36] Roel Van de Paar
...
[ 84%] Building CXX object router/src/router/tests/CMakeFiles/test_issues_bug22572346.dir/issues/test_bug22572346.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
Scanning dependencies of target test_router_config_files
[ 84%] Building CXX object router/src/router/tests/CMakeFiles/test_router_config_files.dir/test_config_files.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 84%] Linking CXX static library libmysql_protocol_static.a
[ 84%] Building CXX object client/dump/CMakeFiles/mysqlpump_lib.dir/trigger.cc.o
[ 84%] Built target mysql_protocol_static
[ 84%] Building CXX object router/src/metadata_cache/CMakeFiles/metadata_cache.dir/src/group_replication_metadata.cc.o
[ 84%] Building CXX object router/src/metadata_cache/tests/CMakeFiles/metadata_cache_tests.dir/helper/mock_metadata.cc.o
...
[ 84%] Building CXX object router/src/router/tests/CMakeFiles/test_issues_bug24909259.dir/issues/test_bug24909259.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/protocol_classic.cc.o
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/psi_memory_key.cc.o
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/query_result.cc.o
Scanning dependencies of target test_router_cluster_metadata
[ 84%] Building CXX object router/src/router/tests/CMakeFiles/test_router_cluster_metadata.dir/test_cluster_metadata.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 84%] Linking CXX shared library ../../../../library_output_directory/libmetadata_cache_tests.so
Scanning dependencies of target test_router_config_generator
[ 84%] Built target metadata_cache_tests
[ 84%] Building CXX object router/src/router/tests/CMakeFiles/test_router_config_generator.dir/test_config_generator.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
Scanning dependencies of target test_router_mysqlrouter_app
[ 84%] Building CXX object router/src/router/tests/CMakeFiles/test_router_mysqlrouter_app.dir/mysqlrouter_app.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 84%] Linking CXX executable ../../../../runtime_output_directory/test_issues_bug22572346
[ 84%] Built target test_issues_bug22572346
Scanning dependencies of target test_router_mysqlrouter_utils
[ 84%] Building CXX object router/src/router/tests/CMakeFiles/test_router_mysqlrouter_utils.dir/mysqlrouter_utils.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/records.cc.o
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/regexp/errors.cc.o
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/regexp/regexp_engine.cc.o
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/regexp/regexp_facade.cc.o
[ 84%] Linking CXX executable ../../../../runtime_output_directory/test_issues_bug24909259
[ 84%] Built target test_issues_bug24909259
Scanning dependencies of target test_router_router_arghandler
[ 84%] Building CXX object router/src/router/tests/CMakeFiles/test_router_router_arghandler.dir/router_arghandler.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/resourcegroups/thread_resource_control.cc.o
[ 84%] Linking CXX executable ../../../../runtime_output_directory/test_router_mysqlrouter_utils
[ 84%] Built target test_router_mysqlrouter_utils
Scanning dependencies of target test_router_console_output
[ 84%] Building CXX object router/src/router/tests/CMakeFiles/test_router_console_output.dir/test_console_output.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/resourcegroups/resource_group_mgr.cc.o
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/resourcegroups/platform/thread_attrs_api_common.cc.o
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/resourcegroups/resource_group_sql_cmd.cc.o
[ 84%] Building CXX object sql/CMakeFiles/sql_main.dir/rpl_group_replication.cc.o
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/rpl_handler.cc.o
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/rpl_transaction_ctx.cc.o
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/rpl_transaction_write_set_ctx.cc.o
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/rpl_trx_tracking.cc.o
[ 85%] Linking CXX executable ../../../../runtime_output_directory/test_router_console_output
[ 85%] Built target test_router_console_output
Scanning dependencies of target test_router_configuration_errors
[ 85%] Building CXX object router/src/router/tests/CMakeFiles/test_router_configuration_errors.dir/test_configuration_errors.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 85%] Linking CXX executable ../../../../runtime_output_directory/test_router_cluster_metadata
[ 85%] Built target test_router_cluster_metadata
Scanning dependencies of target test_router_datatypes
[ 85%] Building CXX object router/src/router/tests/CMakeFiles/test_router_datatypes.dir/test_datatypes.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/rpl_write_set_handler.cc.o
[ 85%] Linking CXX executable ../../../../runtime_output_directory/test_router_router_arghandler
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/rules_table_service.cc.o
[ 85%] Built target test_router_router_arghandler
Scanning dependencies of target test_router_metadata_check
[ 85%] Building CXX object router/src/router/tests/CMakeFiles/test_router_metadata_check.dir/test_metadata_check.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/rwlock_scoped_lock.cc.o
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/sd_notify.cc.o
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/sdi_utils.cc.o
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/session_tracker.cc.o
Scanning dependencies of target test_router_log_filter
[ 85%] Building CXX object router/src/router/tests/CMakeFiles/test_router_log_filter.dir/test_log_filter.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 85%] Linking CXX executable ../../../../runtime_output_directory/test_router_datatypes
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/set_var.cc.o
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/sorting_iterator.cc.o
[ 85%] Built target test_router_datatypes
Scanning dependencies of target test_issues_bug22084430
[ 85%] Building CXX object router/src/router/tests/CMakeFiles/test_issues_bug22084430.dir/issues/test_bug22084430.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[ 85%] Building CXX object sql/CMakeFiles/sql_main.dir/sp.cc.o
[ 85%] Linking CXX executable ../../../../runtime_output_directory/test_router_configuration_errors
[ 85%] Built target test_router_configuration_errors
Scanning dependencies of target test_router_mysql_session
[ 85%] Building CXX object router/src/router/tests/CMakeFiles/test_router_mysql_session.dir/test_mysql_session.cc.o
Unknown file/directory /git/MS-8.0-trunk_opt/router/src/harness/shared/../harness/include.
[19 Dec 2018 12:26] Erlend Dahl
Duplicate of Bug#92162 Cleanup include of non-existing directories