Bug #93624 getpeername
Submitted: 15 Dec 2018 13:44 Modified: 24 May 8:04
Reporter: sdf sdf Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Router Severity:S7 (Test Cases)
Version:8.0.13, 8.0.16 OS:Any
Assigned to: CPU Architecture:Any

[15 Dec 2018 13:44] sdf sdf
Description:
2018-12-15 10:11:12 routing ERROR [7f6d87a46700] routing:simple_redirect: getpeername() failed, errno: 107
2018-12-15 10:11:12 main ERROR [7f6d87a46700]   plugin 'routing:simple_redirect' start failed: routing:simple_redirect: getpeername() failed, errno: 107
2018-12-15 10:15:49 main INFO [7fc79b473880] PID 24185 written to 'Var/run/mysqlrouter/mysqlrouter.pid'
2018-12-15 10:15:49 main INFO [7fc79b473880] Loading all plugins.
2018-12-15 10:15:49 main INFO [7fc79b473880]   plugin 'keepalive:' loading
2018-12-15 10:15:49 main INFO [7fc79b473880]   plugin 'routing:simple_redirect' loading
2018-12-15 10:15:49 main INFO [7fc79b473880] Initializing all plugins.
2018-12-15 10:15:49 main INFO [7fc79b473880]   plugin 'keepalive' initializing
2018-12-15 10:15:49 main INFO [7fc79b473880]   plugin 'routing' initializing
2018-12-15 10:15:49 main INFO [7fc79b473880] Starting all plugins.
2018-12-15 10:15:49 main INFO [7fc796e5e700]   plugin 'keepalive:' starting
2018-12-15 10:15:49 keepalive INFO [7fc796e5e700] keepalive started with interval 60
2018-12-15 10:15:49 keepalive INFO [7fc796e5e700] keepalive
2018-12-15 10:15:49 main INFO [7fc79665d700]   plugin 'routing:simple_redirect' starting

How to repeat:
 getpeername
[20 Dec 2018 8:14] Nicolas JEAN
Same periodical issue

==
2018-12-20 07:12:29 routing ERROR [7f789f7fe700] routing:mysql21_default_rw: getpeername() failed, errno: 107
2018-12-20 07:12:29 main ERROR [7f789f7fe700]   plugin 'routing:mysql21_default_rw' start failed: routing:mysql21_default_rw: getpeername() failed, errno: 107
2018-12-20 07:12:29 main INFO [7f78a824a780] Shutting down. Stopping all plugins.
2018-12-20 07:12:30 routing INFO [7f789e7fc700] [routing:mysql21_default_x_rw] stopped
2018-12-20 07:13:03 main INFO [7f986e334780] Loading all plugins.
2018-12-20 07:13:03 main INFO [7f986e334780]   plugin 'metadata_cache:mysql21' loading
2018-12-20 07:13:03 main INFO [7f986e334780]   plugin 'routing:mysql21_default_ro' loading
2018-12-20 07:13:03 main INFO [7f986e334780]   plugin 'routing:mysql21_default_rw' loading
2018-12-20 07:13:03 main INFO [7f986e334780]   plugin 'routing:mysql21_default_x_ro' loading
2018-12-20 07:13:03 main INFO [7f986e334780]   plugin 'routing:mysql21_default_x_rw' loading
2018-12-20 07:13:03 main INFO [7f986e334780] Initializing all plugins.
2018-12-20 07:13:03 main INFO [7f986e334780]   plugin 'metadata_cache' initializing
2018-12-20 07:13:03 main INFO [7f986e334780]   plugin 'routing' initializing
2018-12-20 07:13:03 main INFO [7f986e334780] Starting all plugins.
2018-12-20 07:13:03 main INFO [7f986aeb1700]   plugin 'metadata_cache:mysql21' starting
2018-12-20 07:13:03 main INFO [7f986a6b0700]   plugin 'routing:mysql21_default_ro' starting
2018-12-20 07:13:03 main INFO [7f9869eaf700]   plugin 'routing:mysql21_default_rw' starting
2018-12-20 07:13:03 main INFO [7f98696ae700]   plugin 'routing:mysql21_default_x_ro' starting
2018-12-20 07:13:03 metadata_cache INFO [7f986aeb1700] Starting Metadata Cache
2018-12-20 07:13:03 main INFO [7f9868ead700]   plugin 'routing:mysql21_default_x_rw' starting
2018-12-20 07:13:03 metadata_cache INFO [7f986aeb1700] Connections using ssl_mode 'PREFERRED'
2018-12-20 07:13:03 main INFO [7f986e334780] Running.
2018-12-20 07:13:03 routing INFO [7f986a6b0700] [routing:mysql21_default_ro] started: listening on 0.0.0.0:6447
2018-12-20 07:13:03 routing INFO [7f9869eaf700] [routing:mysql21_default_rw] started: listening on 0.0.0.0:3306
2018-12-20 07:13:03 routing INFO [7f98696ae700] [routing:mysql21_default_x_ro] started: listening on 0.0.0.0:64470
2018-12-20 07:13:03 routing INFO [7f9868ead700] [routing:mysql21_default_x_rw] started: listening on 0.0.0.0:64460
2018-12-20 07:13:03 metadata_cache INFO [7f986aeb1700] Potential changes detected in cluster 'mysql21' after metadata refresh
2018-12-20 07:13:03 metadata_cache INFO [7f986aeb1700] Metadata for cluster 'mysql21' has 1 replicasets:
2018-12-20 07:13:03 metadata_cache INFO [7f986aeb1700] 'default' (3 members, single-master)
2018-12-20 07:13:03 metadata_cache INFO [7f986aeb1700]     nsql211:3306 / 33060 - role=HA mode=RO
2018-12-20 07:13:03 metadata_cache INFO [7f986aeb1700]     nsql213:3306 / 33060 - role=HA mode=RW
2018-12-20 07:13:03 metadata_cache INFO [7f986aeb1700]     nsql212:3306 / 33060 - role=HA mode=RO
2018-12-20 07:13:03 metadata_cache INFO [7f986e333700] Starting metadata cache refresh thread
==
[8 Apr 14:55] John Goldstein
I tried running this with the generic linux binary on Debian 7 on 17 servers as part of a project to pull their databases out and upgrade them. So I'm running the router to simply redirect traffic to make the transition smooth and seamless. In anticipation of upgrading to MySQL 8, I had a stanza in the config file to redirect traffic from 33060 to 33070. On 5 of the 17 machines, it crashed with this error within several hours. On those five machines, I tested 5 different approaches:
1) Remove the x protocol stanza
2) Keep the x protocol stanza, but use 8.0.12
3) Same as 2, but using 8.0.11
4) Same as 2, but using 8.0.4 rc
5) Same as 2, but using 8.0.3 dmr

Three days later, they're all still running.
[14 Apr 22:33] John Goldstein
It turns out only redirecting ports I'm actually using delays the error from cropping up and crashing the router. After about a week MySQL Router crashed on 1/17 instances with that error. Now I'm trying 8.0.12.
[24 May 7:37] Umesh Shastry
Hello!

Thank you for the report.
Observed with 8.0.16 build while reproducing an issue.

regards,
Umesh
[24 May 7:58] Jan Kneschke
Posted by developer:
 
This is a duplicate of Bug#29382585
[24 May 8:04] Umesh Shastry
Thank you Jan for the base bug details. 

Hi,

This issue has been fixed internally, per internal bug change log:

*** PHOLSON  philip.olson Sat May 18 2019 02:03:45 GMT+0530 (IST)***
Fixed as of the upcoming MySQL Router 8.0.17 release, and here's the
changelog entry:

An uncaught exception was generated if a client socket was shutdown the
client peer address was retrieved.

Thank you for the bug report. 

Closure details will be published post 8.0.17 release at https://dev.mysql.com/doc/relnotes/mysql-router/en/news-8-0-17.html 

thanks,
Umesh