Bug #93615 MySQL5.7.24 ERROR 1872 (HY000): Slave failed to initialize relay log info struc
Submitted: 14 Dec 2018 10:32 Modified: 14 Dec 2018 11:14
Reporter: chaofei yu Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:5.7.24 OS:CentOS
Assigned to: CPU Architecture:Any

[14 Dec 2018 10:32] chaofei yu
Description:
when my.cnf configured like this:

master_info_repository = TABLE
relay_log_info_repository = TABLE
relay_log_recovery = 1
sync_binlog = 1
# GTID #
gtid_mode = ON
enforce_gtid_consistency = 1
relay_log = /opt/mysql/log/relaylog/3306/mysql-relay

go to "how to repeat" 

How to repeat:
master-slave, asynchronous replication
all blow staff did in slave db
1. reset slave all;
2.  start slave;    #must do, else this can not repeat
ERROR 1200 (HY000): The server is not configured as slave; fix in config file or with CHANGE MASTER TO; 
3. change  my.cnf config from "relay_log = /opt/mysql/log/relaylog/3306/mysql-relay" to "relay_log = /opt/mysql/log/relaylog/3306/mysql-relay-relay"
4. restart slave  mysqld process "systemctl restart mysqld_3306"
5. CHANGE MASTER TO MASTER_HOST = 'master_ip', MASTER_USER = 'repl', MASTER_PASSWORD =’repl’, MASTER_PORT = 3306, MASTER_AUTO_POSITION = 1;
6. start slave;
ERROR 1872 (HY000): Slave failed to initialize relay log info structure from the repository
[14 Dec 2018 11:10] chaofei yu
the word 'blow' change to 'below'
[14 Dec 2018 11:14] Umesh Shastry
Hello Jeremy,

Thank you for the report.
Imho this is most likely duplicate of Bug #93397, please see Bug #93397

regards,
Umesh
[25 Mar 5:57] kfpanda kf
In which version will this problem be fixed?