Bug #93592 mysql crash got signal 6 ,free(): invalid next size (normal):
Submitted: 13 Dec 2018 14:32 Modified: 15 Jan 12:59
Reporter: Mr. Left Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Performance Schema Severity:S3 (Non-critical)
Version:5.7.21 OS:Linux
Assigned to: CPU Architecture:x86
Tags: crash

[13 Dec 2018 14:32] Mr. Left
Description:
mysqld crashed with the following log:

03:00:01 UTC - mysqld got signal 6 ;

*** Error in `/mysql/mysoft/mysql5.7/bin/mysqld': free(): invalid next size (normal): 0x00007fe7bc00c7c0 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x7c619)[0x7fee45a77619]
/mysql/mysoft/mysql5.7/bin/mysqld[0x1156edf]
/mysql/mysoft/mysql5.7/bin/mysqld(_Z23trx_free_for_backgroundP5trx_t+0x1a)[0x115747a]
/mysql/mysoft/mysql5.7/bin/mysqld[0x100b065]
/mysql/mysoft/mysql5.7/bin/mysqld[0x8330ce]
/mysql/mysoft/mysql5.7/bin/mysqld(_Z24plugin_foreach_with_maskP3THDPPFcS0_P13st_plugin_intPvEijS3_+0x18c)[0xd5575c]
/mysql/mysoft/mysql5.7/bin/mysqld(_Z24plugin_foreach_with_maskP3THDPFcS0_P13st_plugin_intPvEijS3_+0x1d)[0xd5587d]
/mysql/mysoft/mysql5.7/bin/mysqld(_ZN3THD17release_resourcesEv+0x20a)[0xcf284a]
/mysql/mysoft/mysql5.7/bin/mysqld(handle_connection+0x8f)[0xe074ff]
/mysql/mysoft/mysql5.7/bin/mysqld(pfs_spawn_thread+0x174)[0xf81144]
/lib64/libpthread.so.0(+0x7e25)[0x7fee47036e25]
/lib64/libc.so.6(clone+0x6d)[0x7fee45af334d]

Please check the full error log in attachment.

How to repeat:
No idea
[13 Dec 2018 14:33] Mr. Left
mysql error log

Attachment: mysqld_err.log (application/octet-stream, text), 37.84 KiB.

[14 Dec 2018 14:15] Sinisa Milivojevic
Hi,

Thank you for your report.

However, in order to verify it, we must be able to repeat it. I do not think that this is our bug, since GNU malloc library reports that its own internal data is corrupted. Hence, I would recommend you to check your RAM modules thoroughly. 

If those are OK, then it could be a glitch that happens quite a lot in low quality RAM modules. However, if you are using ECC memory modules, with 2 bits checking, 1 bit correcting, then it is unlikely that your RAM is a problem.

If that is a case, we would like to verify the bug, providing you send us a fully repeatable test case, that would always lead to the error from the title of this report.
[15 Jan 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".