Bug #93577 mysql ERROR, InnoDB: InnoDB: Unable to allocate memory of size 1065016.
Submitted: 12 Dec 2018 15:20 Modified: 12 Dec 2018 15:58
Reporter: PAVAN BHANDARI Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.6.31 OS:Microsoft Windows (Windows Server)
Assigned to: CPU Architecture:Any

[12 Dec 2018 15:20] PAVAN BHANDARI
Description:
mysql crashes and does not start until i stop and start back mysql manually. I looked at the server logs and below are the errors. 

Timestamp, Thread, Type, Details
2018-12-12 00:49:18, 1524, ERROR, InnoDB:  InnoDB: Unable to allocate memory of size 1065016.
, , , 2018-12-12 00:49:18 f84  InnoDB: Assertion failure in thread 3972 in file ha_innodb.cc line 17303
, , , InnoDB: We intentionally generate a memory trap.
, , , InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
, , , InnoDB: If you get repeated assertion failures or crashes, even
, , , InnoDB: immediately after the mysqld startup, there may be
, , , InnoDB: corruption in the InnoDB tablespace. Please refer to
, , , InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
, , , InnoDB: about forcing recovery.
2018-12-12 00:50:13, 1524, ERROR, InnoDB:  InnoDB: Unable to allocate memory of size 1065016.
, , , 2018-12-12 00:50:13 6a4  InnoDB: Assertion failure in thread 1700 in file ha_innodb.cc line 17303
, , , InnoDB: We intentionally generate a memory trap.
, , , InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
, , , InnoDB: If you get repeated assertion failures or crashes, even
, , , InnoDB: immediately after the mysqld startup, there may be
, , , InnoDB: corruption in the InnoDB tablespace. Please refer to
, , , InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
, , , InnoDB: about forcing recovery.

How to repeat:
not sure
[12 Dec 2018 15:53] Miguel Solorzano
Thank you for taking the time to report a problem.  Unfortunately you
are not using a current version of the product you reported a problem
with (current version 5.6.42) -- the problem might already be fixed. Please download a new version from http://www.mysql.com/downloads/.

Also, there is no test case provided in the bug report and hence there
is nothing we can verify here.  If you are able to reproduce the bug
with one of the latest versions, please attach the exact reproducible
test case and change the version on this bug report to the version you
tested.  Again, thank you for your continued support of MySQL.
[12 Dec 2018 15:58] PAVAN BHANDARI
I have been using MYSQL 5.6.31 since 2016 and never had this issue before. This issue started recently.