Bug #93576 after upgrading to mojave, my cursor doesn't work in workbench
Submitted: 12 Dec 2018 14:28 Modified: 25 Apr 14:02
Reporter: mike coutinho Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:8.0.16 OS:Mac OS X (mojave)
Assigned to: CPU Architecture:x86

[12 Dec 2018 14:28] mike coutinho
Description:
After upgrading over the weekend to OSX Mojave, my cursor doesn't work.  I recorded a video of it and will upload it.  

At the top of the query window, if I scroll down anywhere in my queries with my mouse, it moves.  When I use the up and down arrows, the cursor bounces back and forth like PONG  or a tennis ball on the screen, not moving the actual screen.  Up does this every time, down seems to just go off the screen.  

I tried to dump all of the user settings in ~/Library/Application Support/MySQL and that did nothing.  

How to repeat:
No idea.  Does it every time for me.

Suggested fix:
Make it work? No idea.
[12 Dec 2018 14:29] mike coutinho
video of what I am doing with the cursor

Attachment: workbench_cursor.mov.zip (application/zip, text), 2.77 MiB.

[12 Dec 2018 18:50] Miguel Solorzano
Thank you for the bug report.
[21 Jan 19:20] mike coutinho
This doesn't work in 8.0.14 either.  Can't scroll with keyboard.  Find doesn't work.
[22 Jan 9:07] Mike Lischke
We are aware of this ugly problem (caused by the 3rd party control Scintilla) and will solve it in one of the next releases.

As a workaround scroll the editor content vertically once after opening and the arrow keys will start working as expected.
[13 Feb 14:52] Jaime Herrán Molano
Hi, I am experiencing the exactly same issue even with the latest version (8.0.15).  The workaround described doesn't work for me.
[13 Feb 15:06] Jaime Herrán Molano
For me the workaround was downgrade to the version 6.3.10. Now the arrow keys and find function work properly again.
[22 Apr 16:02] Bryan Nelson
Hello,

I'm wondering if there is any update coming on this.  I am going to try 6.3.10 as another commenter suggested in the meantime.
[25 Apr 14:02] mike coutinho
This still doesn't work in 8.0.16.
[7 May 11:51] Ricardo Pastor
Affects me too.