Bug #93536 Query Execution Should Not Require Modal Dialog
Submitted: 10 Dec 2018 7:02 Modified: 12 Dec 2018 8:14
Reporter: Aaron Greenspan Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.13 OS:Mac OS X
Assigned to: CPU Architecture:Any

[10 Dec 2018 7:02] Aaron Greenspan
Description:
When executing an UPDATE or INSERT query or multiple such queries in MySQL Workbench, a modal dialog appears that prevents any further action from being taken in Workbench itself, and gets in the way (visually) of other non-Workbench application windows even if Workbench is hidden with Command-H. This can inhibit work for long periods of time depending upon the queries being executed, the number of queries, and their relative complexity.

How to repeat:
Execute, for example, 500 slow write queries in sequence. Wait. Keep waiting. For a really long time.

Suggested fix:
Instead of using a modal dialog, add a new row to the bottom of the status ("Action Output") pane at the bottom of MySQL Workbench. Put the progress bar in the Action column so it's easy to monitor progress. If the reason why this hasn't been done already is that Workbench only opens one database connection for all of its various tabs and operations, consider making the program multi-connection (multi-threaded) so that read queries can still take place without interfering with simultaneous write operations. This would have the advantage of also allowing multiple read queries if there were one connection established per tab-with-an-active-query.
[10 Dec 2018 10:25] Miguel Solorzano
Thank you for the bug report. Please provide a screenshot of the modal dialog. Thanks in advance.
[12 Dec 2018 6:56] Aaron Greenspan
Query Execution Modal Dialog Box (content blurred for privacy)

Attachment: modal.png (image/png, text), 110.18 KiB.

[12 Dec 2018 6:57] Aaron Greenspan
As of MySQL Workbench 8, the syntax highlighting is also off in the query portion of the modal dialog, and for some reason it shows up with the SQL text shifted several pixels horizontally to the right. This didn't used to happen.
[12 Dec 2018 8:14] Mike Lischke
What you see is the query review dialog (its title also says this), which can be used to check the update or insert queries that Workbench wants to send to the server. It's a safety measure! However, you can switch it off by unchecking the checkbox titled "Confirm Data Changes" in preferences -> SQL Editor -> SQL Execution.

Regarding the horizontal shift in the review code editor: this is a problem of the used 3rd party editor control. As soon as this is fixed there we will update Workbench.