Bug #93441 Problems with ODBC connector in mysql + access queries
Submitted: 1 Dec 2018 21:12 Modified: 2 Dec 2018 15:09
Reporter: JuCePi . Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:8.0.13 OS:Microsoft Windows (Pro 10)
Assigned to: CPU Architecture:x86 (I5 6ta generation)

[1 Dec 2018 21:12] JuCePi .
Description:
I am working with mysql see 8.0.13 and all its applications of this version
I have application in acces + mysql. Start in a form choosing the current year (2018) that is saved in a tempvars and then open another form with a filtered consulat for the selected year.
The problem is that the consultant does not show all the records that go from the year (3506 to the month of November), only shows 986 records until the month of April.
When I choose previous years (2017.2016 etc) if you show me the complete records.

How to repeat:
SELECT Year ([data_date]) AS year, dbo_viewDocuments.ID_EXPEDIENT, dbo_viewDocuments.Date_Day, dbo_viewDocuments.Provided, dbo_viewDocuments.Offices, dbo_viewDocuments.desc_office, dbo_viewDocuments.Resolution, dbo_viewDocuments.desc_Subject, dbo_viewDocuments.Details, dbo_viewDocuments.User, dbo_viewDocuments. desc_Situation, dbo_viewDocumentos.Observaciones, dbo_viewDocumentos.Fecha_proceso
FROM dbo_viewDocuments
WHERE (((Year ([fecha_ingreso])) = [tempvars]! [Anñologin]));

Suggested fix:
I had to go down to odbc connector version 5.2.7 to find a solution, that is, with this connector if it shows all the records as it should be.
[2 Dec 2018 15:09] Miguel Solorzano
Not enough information was provided for us to be able to handle this bug. Please re-read the instructions at http://bugs.mysql.com/how-to-report.php

If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Without data we can't run the alleged failed queries.