Bug #93385 query_cache_size limited 4GB using mysql 5.6.42 64bit and windows 2012r2 64bit
Submitted: 28 Nov 2018 13:59 Modified: 28 Nov 2018 15:16
Reporter: Rodrigo itmnetworks Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S5 (Performance)
Version:5.6.42 OS:Microsoft Windows (w2012 r2 64bit )
Assigned to: CPU Architecture:x86 (192GB RAM)
Tags: query_cache_size

[28 Nov 2018 13:59] Rodrigo itmnetworks
Description:
hello,

i have one server running windows 2012 r2 64bit with 192gb ram

i have mysql 5.6.42 community edition compiled for Win64 ( x86_64 )

i need setup 64GB ram on query_cache_size

i have on my.ini  query_cache_size=64G

but looking on the system, query_cache_size is limited to 4GB

query cache size with 4G is the limit for 32bit system

innodb_buffer_pool_size running perfect with 64G
key_buffer_size running perfect with 8G

only query_cache_size stop at 4G 
i try
query_cache_size=5G
query_cache_size=10G
query_cache_size=30G
query_cache_size=64G

don't runn more than 4G

this is a bug on query cache ? or i need send any parameter to force to run mysqld.exe with 64bit ?

answer the question if a really need query cache and if i really need myisam, yes, i need :-)

How to repeat:
install on windows 2012 r2   mysql 5.6.42 64bit and setup more than 4GB on query_cache_size
[28 Nov 2018 15:16] Miguel Solorzano
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=79922.