Bug #93316 MySql WorkBench Crash
Submitted: 23 Nov 2018 13:19 Modified: 26 Nov 2018 10:06
Reporter: Dorin Calugaru Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version: OS:Microsoft Windows
Assigned to: CPU Architecture:x86

[23 Nov 2018 13:19] Dorin Calugaru
Description:
MySql WorkBench crashes when the query is stoped on fetching data.
Cases when the query fetching takes some time. This might be from closing the connection with the server on idle time.

How to repeat:
Let Workbench idle for some time, then execute a query, when the query duration is listed and the fetch is not, stop the query execution. 
The result is that MySql Workbench freezes and becomes not responsive.

Suggested fix:
Check the connection to the server before starting the query, and reopen it when the query begins executing(If the problem is with the idle state).
[23 Nov 2018 13:38] Miguel Solorzano
Thank you for the bug report. Please inform the exactly version of WorkBench and server you are querying. Thanks.
[23 Nov 2018 13:41] Dorin Calugaru
Workbench 6.3 CE
MySql Server 5.7.14 Community Server (GPL)
[23 Nov 2018 13:53] Miguel Solorzano
Please try version WorkBench 8.0.13 and your server is quite older too, current version is 5.7.24.
[23 Nov 2018 13:56] Dorin Calugaru
Thank you, will do. I will let you know if the problem is still persistent
[23 Nov 2018 15:31] Miguel Solorzano
Please specify the kind of connection: localhost. remote (slow internet connection). Thanks in advance.
[23 Nov 2018 15:34] Dorin Calugaru
mainly remote connection, internet speed usually around 100 Mbit/s
[26 Nov 2018 10:06] Miguel Solorzano
Thank you for the feedback. Duplicate/related to https://bugs.mysql.com/bug.php?id=93080.