Bug #93303 Failed To Enable SSL with Error SSL_CTX_set_default_verify_paths on Windows
Submitted: 23 Nov 2018 1:34 Modified: 24 Nov 2018 3:31
Reporter: toshinobu suzuki Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Windows Severity:S3 (Non-critical)
Version:8.0.13 OS:Microsoft Windows (Windows 10 Home)
Assigned to: CPU Architecture:x86

[23 Nov 2018 1:34] toshinobu suzuki
Description:
I done install MySQL in Windows by zip.
I was success 『mysqld.exe --initialized --console』.
MySQL create CA sertificat in datadir.
  "C:\Users\ts0818\Desktop\mysqlData\public_key.pem"
  "C:\Users\ts0818\Desktop\mysqlData\server-cert.pem"
  "C:\Users\ts0818\Desktop\mysqlData\server-key.pem"
  "C:\Users\ts0818\Desktop\mysqlData\ca.pem"
  "C:\Users\ts0818\Desktop\mysqlData\ca-key.pem"
  "C:\Users\ts0818\Desktop\mysqlData\client-cert.pem"
  "C:\Users\ts0818\Desktop\mysqlData\client-key.pem"
  "C:\Users\ts0818\Desktop\mysqlData\private_key.pem"
I edit my.cnf.
"C:\my.cnf"
  [client]
  ssl-ca=C:\\Users\\ts0818\\Desktop\\mysqlData\\ca-cert.pem
  ssl-cert=C:\\Users\\ts0818\Desktop\\mysqlData\\client-cert.pem
  ssl-key=C:\\Users\\ts0818\\Desktop\\mysqlData\\client-key.pem

  # options for mysqld80 service
  [mysqld]
  ssl-ca=C:\\Users\\ts0818\\Desktop\\mysqlData\\ca-cert.pem
  ssl-cert=C:\\Users\\ts0818\\Desktop\\mysqlData\\server-cert.pem
  ssl-key=C:\\Users\\ts0818\\Desktop\\mysqlData\\server-key.pem
  basedir = "C:\\Program Files\\mysql-8.0.13"
  datadir = "C:\\Users\\ts0818\\Desktop\\mysqlData"
  #tmpdir = "C:\\Program Files\\mysql-8.0.13\\temp"

  character_set_server = UTF8MB4

  port = 3309
  enable-named-pipe
  socket = mypipe80

Then, I done 『"C:\Program Files\mysql-8.0.13\bin\mysqld.exe" --install mysql-8.0.13 --default-file="C:\Program Files\mysql-8.0.13\my.cnf"』.
Service Successfuly installed.

Then, I done 『net start mysql-8.0.13』.
But,failed.
log message.
[Warning] [MY-010069] [Server] Failed to set up SSL because of the following SSL library error: SSL_CTX_set_default_verify_paths failed

How to repeat:
Done Description.
[23 Nov 2018 1:47] toshinobu suzuki
I miswrote "C:\my.cnf", but "C:\Program Files\mysql-8.0.13\my.cnf" is right in my case.
[23 Nov 2018 2:39] toshinobu suzuki
I miswrote.
This is right.
"C:\Program Files\mysql-8.0.13\my.cnf"
[client]
ssl-ca=C:\\Users\\ts0818\\Desktop\\mysqlData\\ca.pem
ssl-cert=C:\\Users\\ts0818\Desktop\\mysqlData\\client-cert.pem
ssl-key=C:\\Users\\ts0818\\Desktop\\mysqlData\\client-key.pem

# options for mysql8.0.13 service
[mysql8.0.13]
ssl-ca=C:\\Users\\ts0818\\Desktop\\mysqlData\\ca-key.pem
ssl-cert=C:\\Users\\ts0818\\Desktop\\mysqlData\\server-cert.pem
ssl-key=C:\\Users\\ts0818\\Desktop\\mysqlData\\server-key.pem
basedir = "C:\\Program Files\\mysql-8.0.13"
datadir = "C:\\Users\\ts0818\\Desktop\\mysqlData"
#tmpdir = "C:\\Program Files\\mysql-8.0.13\\temp"

# 文字コードを UTF-8 に指定
character_set_server = UTF8MB4

port = 3309
enable-named-pipe
socket = mypipe80

but, 『[Warning] [MY-010069] [Server] Failed to set up SSL because of the following SSL library error: SSL_CTX_set_default_verify_paths failed』.
[23 Nov 2018 3:04] toshinobu suzuki
I corrected the mistakes on my.cnf.
"C:\Program Files\mysql-8.0.13\my.cnf"
[client]
ssl-ca=C:\\Users\\ts0818\\Desktop\\mysqlData\\ca.pem
ssl-cert=C:\\Users\\ts0818\Desktop\\mysqlData\\client-cert.pem
ssl-key=C:\\Users\\ts0818\\Desktop\\mysqlData\\client-key.pem

# options for mysql8.0.13 service
[mysqld]
ssl-ca=C:\\Users\\ts0818\\Desktop\\mysqlData\\ca-key.pem
ssl-cert=C:\\Users\\ts0818\\Desktop\\mysqlData\\server-cert.pem
ssl-key=C:\\Users\\ts0818\\Desktop\\mysqlData\\server-key.pem
basedir = "C:\\Program Files\\mysql-8.0.13"
datadir = "C:\\Users\\ts0818\\Desktop\\mysqlData"
#tmpdir = "C:\\Program Files\\mysql-8.0.13\\temp"

# 文字コードを UTF-8 に指定
character_set_server = UTF8MB4

port = 3309
enable-named-pipe
socket = mypipe80

but, 『[Warning] [MY-010069] [Server] Failed to set up SSL because of the following SSL library error: SSL_CTX_set_default_verify_paths failed』
[23 Nov 2018 10:27] Miguel Solorzano
We're sorry, but the bug system is not the appropriate forum for asking help on using MySQL products. Your problem is not the result of a bug.

Support on using our products is available both free in our forums at http://forums.mysql.com/ and for a reasonable fee direct from our skilled support engineers at http://www.mysql.com/support/

Thank you for your interest in MySQL.

https://support.oracle.com/knowledge/Oracle%20Database%20Products/2384231_1.html
[23 Nov 2018 13:53] toshinobu suzuki
Mr.Miguel Solorzano
Thank you for your message.
I try to check http://forums.mysql.com/
[24 Nov 2018 3:31] toshinobu suzuki
I success MySQL Service in Windows.
I move ca cetification file which is created in datadir by MySQL another dir.
C:\Users\ts0818\Desktop\mysqlSSL
  "C:\Users\ts0818\Desktop\mysqlSSL\server-cert.pem"
  "C:\Users\ts0818\Desktop\mysqlSSL\server-key.pem"
  "C:\Users\ts0818\Desktop\mysqlSSL\ca.pem"
  "C:\Users\ts0818\Desktop\mysqlSSL\ca-key.pem"
  "C:\Users\ts0818\Desktop\mysqlSSL\client-cert.pem"
  "C:\Users\ts0818\Desktop\mysqlSSL\client-key.pem"
  "C:\Users\ts0818\Desktop\mysqlSSL\private_key.pem"
  "C:\Users\ts0818\Desktop\mysqlSSL\public_key.pem"

Then I edit my.cnf.
"C:\Program Files\mysql-8.0.13\my.cnf"
  [client]
  ssl-ca=C:\\Users\\ts0818\\Desktop\\mysqlSSL\\ca.pem
  ssl-cert=C:\\Users\\ts0818\Desktop\\mysqlSSL\\client-cert.pem
  ssl-key=C:\\Users\\ts0818\\Desktop\\mysqlSSL\\client-key.pem

  # options for mysql8.0.13 service
  [mysqld]
  ssl-ca=C:\\Users\\ts0818\\Desktop\\mysqlSSL\\ca-key.pem
  ssl-cert=C:\\Users\\ts0818\\Desktop\\mysqlSSL\\server-cert.pem
  ssl-key=C:\\Users\\ts0818\\Desktop\\mysqlSSL\\server-key.pem
  basedir = "C:\\Program Files\\mysql-8.0.13"
  datadir = "C:\\Users\\ts0818\\Desktop\\mysqlData"
  #tmpdir = "C:\\Program Files\\mysql-8.0.13\\temp"

  # 文字コードを UTF-8 に指定
  character_set_server = UTF8MB4

  port = 3309
  enable-named-pipe
  socket = mypipe80

And, I done this command in commandprompt.
『"C:\Program Files\mysql-8.0.13\bin\mysqld.exe" remove mysqld8.0.13
Service successfully removed.』
『"C:\Program Files\mysql-8.0.13\bin\mysqld.exe" --install mysqld8.0.13 --defaults-file="C:\Program Files\mysql-8.0.13\my.cnf"』
Service successfully installed.
『net start mysqld8.0.13』
mysqld8.0.13 サービスを開始します..
mysqld8.0.13 サービスは正常に開始されました。

Mr.Miguel Solorzano, I’m gratful for your help.