Bug #93163 Mysql workbench exits when connecting
Submitted: 12 Nov 2018 13:07 Modified: 14 Nov 2018 7:22
Reporter: darius val Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:MySQL Workbench Community (GPL) for Linux/Unix version 6.3.10 CE build 12092614 (64 bit) OS:Ubuntu
Assigned to: CPU Architecture:Any

[12 Nov 2018 13:07] darius val
Description:
I also today cannot connect anymore even to docker. 

Log:

14:53:50 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: /usr/share/mysql-workbench
	plugin path: /usr/lib/mysql-workbench/plugins
	struct path: /usr/share/mysql-workbench/grt
	module path: /usr/lib/mysql-workbench/modules
	library path: /usr/share/mysql-workbench/libraries
	user data dir: /home/darius/.mysql/workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
14:53:50 [INF][      WBContext]: WbContext::init
14:53:51 [INF][            WBA]: Looking for extension modules for WBA...
14:53:51 [INF][            WBA]: 0 extension modules found
14:53:51 [WRN][            grt]: /home/darius/.mysql/workbench/connections.xml:25: link '66c6f07f-e679-11e8-a12b-e89a8fe9e73f' <object GrtObject> key=owner could not be resolved
14:53:51 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Linux/Unix version 6.3.10 CE build 12092614 (64 bit)
	Configuration Directory: /home/darius/.mysql/workbench
	Data Directory: /usr/share/mysql-workbench
	Cairo Version: 1.14.6
	OS: Ubuntu 16.04 x86_64
	CPU: 2x Intel(R) Pentium(R) CPU B960 @ 2.20GHz (1025.832MHz) - 7.65GiB RAM
No video adapter info available
	Distribution: Ubuntu 16.04.4 LTS

	Fips mode enabled: no

14:53:51 [INF][    WQE backend]: Found auto-save workspace /home/darius/.mysql/workbench/sql_workspaces/Local_instance_3306-1.autosave
14:53:51 [INF][    WQE backend]: Found auto-save workspace /home/darius/.mysql/workbench/sql_workspaces/Vop_docker-1.autosave
14:54:08 [ERR][    Preferences]: Logger set to level 'debug3' in Preferences menu
14:54:09 [DB2][            grt]: wb.form.showOptions finished in 5.97s
14:54:12 [DB3][SQL Editor Form]: Creating KeepAliveInterval timer...
14:54:12 [DB1][ mforms backend]: Looking up password for 'root'@'Mysql@127.0.0.1:33306' has succeeded
14:54:12 [DB3][    WQE backend]: Connecting SQL editor...
14:54:12 [DB3][       GRT task]: Sending task "execute sql queries" to dispatcher (wait)...
14:54:12 [DB1][  GRTDispatcher]: starting worker thread
14:54:12 [DB1][  GRTDispatcher]: worker thread running
14:54:12 [DB3][  GRTDispatcher]: Running task "execute sql queries"
14:54:12 [DB2][SQL Editor Form]: Notifying server state change of Mysql@127.0.0.1:33306 to running
14:54:12 [INF][SQL Editor Form]: Opened connection 'Vop docker' to MySQL Community Server (GPL) version 5.7.23
14:54:12 [DB1][      WBContext]: Saved connection list (MySQL: 2)
14:54:12 [DB3][    WQE backend]: Connection to SQL editor succeeded
14:54:12 [DB3][  GRTDispatcher]: Task "execute sql queries" finished
14:54:12 [DB3][       GRT task]: Sending task "Live Schema Refresh Task" to dispatcher (don't wait)...
14:54:12 [DB1][  GRTDispatcher]: starting worker thread
14:54:12 [DB3][MySQL Name Cache]: Creating worker thread
14:54:12 [DB1][  GRTDispatcher]: worker thread running
14:54:12 [DB2][  column_widths]: Using column width cache file /home/darius/.mysql/workbench/cache/Vop_docker.column_widths
14:54:12 [DB3][  GRTDispatcher]: Running task "Live Schema Refresh Task"
14:54:12 [DB2][MySQL Name Cache]: Entering worker thread
14:54:12 [DB3][MySQL Name Cache]: Updating schema listSaved connection list (MySQL: 2)
14:54:12 [DB1][      WBContext]: Saved connection list (MySQL: 2)
14:54:12 [DB2][MySQL Name Cache]: Leaving worker thread
14:54:12 [DB2][SQL Editor Form]: Updating SQL menu and toolbar
14:54:12 [DB2][SQL Editor Form]: Updating SQL menu and toolbar
14:54:12 [DB2][SQL Editor Form]: Updating SQL menu and toolbar

How to repeat:
I double click on connection rectangle and mysql workbench closes.

Weird thing that this looks like started happening after I had to power of my PC with physical button because it was not responding.

Until today it worked fine with docker connection.

I think I tried to update earlier to latest but without success.
[13 Nov 2018 9:55] Miguel Solorzano
Connected

Attachment: 93163.png (image/png, text), 197.13 KiB.

[13 Nov 2018 9:56] Miguel Solorzano
Thank you for the bug report. I couldn't repeat with version 8.0.13.
[14 Nov 2018 6:47] darius val
Added version
[14 Nov 2018 6:48] darius val
On 8 you cannot reproduce because it happened on version 6.

And when I tried some day, I could not update to latest version, I think it still kept 6 version, but can't remember exactly.

Added to the form version information.
[14 Nov 2018 7:01] Miguel Solorzano
Bug report is checked against latest version which now is 8.0.13 there isn't back port fix for previous obsolete version like 6.3.10.
[14 Nov 2018 7:17] darius val
:( ok, now trying phpstorm database browser then. Btw also today by miracle it connets to docker again.
[14 Nov 2018 7:18] darius val
Ok, maybe you can then fix not updating to latest version on ubuntu 16 ?
[14 Nov 2018 7:22] darius val
Btw in general there are so many bugs. If you have no enough programmers to fix the bugs, maybe you can make a paid version which could pay for the programmers and finnaly fix those bugs? Like 20 $ a year maybe would not be big sum of money but if there are like 100k users who would pay - you could get 2 millions and with that sum could maybe at least fix the bugs. We are wasting so much time othewise and it would be really cheaper for us to pay 20 $ per year instead of wasting our time by trying to find out why it does not work.