Bug #9312 Incompatibily issues between scripts of QB and Command client
Submitted: 21 Mar 2005 12:53 Modified: 22 Sep 2005 11:40
Reporter: Emanuele Dolis Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Query Browser Severity:S3 (Non-critical)
Version:1.1.5 OS:Microsoft Windows (Windows XP SP2)
Assigned to: Mike Lischke CPU Architecture:Any

[21 Mar 2005 12:53] Emanuele Dolis
Description:
Sorry for reposting this issue, it's already been classified as 'not a bug' but i think that being unable to run without errors scripts used in the command line client is a bug (unless we create a new type of script, the QB script)

in bug report #9192  and #9293 I wrote
-----
QB throws out an error when finds directives like \T or \t or \. which enable tee

This is quite annoying since logfiles are critical in debugging...
---

How to repeat:
create this script
_________
\T C:\test.log
\. z:\somefile.sql
\t
__________

the script does work in the command line client, doesn't in QB (Syntax error)

Suggested fix:
Either set the script parser to ignore \. \T \t and similar command line commands, or support them (maybe this will turn into a feature request)

BUT the script shouldn't throw an error, a warning at most....

Thanks
[22 Sep 2005 11:40] Mike Lischke
The log functionality is definitely something worth to be added to MySQL Query Browser. However ignoring a syntax error and make it a warning instead is not what QB is able to do. The commands you enter are directly feed to the server (with very few exceptions). Filtering out those commands you want warnings instead errors for requires to parse the input like the command line client does, which in turn would actually be almost the necessary implementation to support that kind of log file syntax. However this is a feature request as it is not a wrong behavior of a certain (described) functionality. To make it clearer: MySQL Query Browser is made to work with SQL scripts and so requires valid SQL syntax. It is in many aspects different to the command line client (otherwise it would be needless), hence you cannot expect everything that works on the command line also works in QB (and vice versa).

Mike