Bug #93093 Some test cases cannot pass with valgrind option.
Submitted: 6 Nov 2018 11:03 Modified: 29 Nov 2018 6:12
Reporter: Rungong An Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S7 (Test Cases)
Version:5.7.24 OS:CentOS
Assigned to: CPU Architecture:Any

[6 Nov 2018 11:03] Rungong An
Description:
These tests cannot pass with valgrind option:

innodb.check_sector_size main.myisam_explain_json_non_select_none innodb.partition-upgrade main.innodb_explain_json_non_select_none main.mysql_locale_posix main.myisam_explain_json_non_select_all rpl.rpl_semi_sync_shutdown_hang auth_sec.mysql_protocol_types main.innodb_explain_json_non_select_all innodb.create_isl_with_direct

How to repeat:
./mtr --force --parallel=auto --big-test --skip-ndb --max-test-fail=0 --timer --timestamp --testcase-timeout=120 --suite-timeout=600 --valgrind innodb.check_sector_size main.myisam_explain_json_non_select_none innodb.partition-upgrade main.innodb_explain_json_non_select_none main.mysql_locale_posix main.myisam_explain_json_non_select_all rpl.rpl_semi_sync_shutdown_hang auth_sec.mysql_protocol_types main.innodb_explain_json_non_select_all innodb.create_isl_with_direct

Suggested fix:
None
[29 Nov 2018 6:12] Rungong An
My env error, not a bug of mysql.