Bug #93088 Fresh Installation of MySQL APT Repository
Submitted: 5 Nov 2018 20:48 Modified: 17 Jan 8:16
Reporter: Austregecilio Cruz Neto Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Package Repos and Docker Images Severity:S3 (Non-critical)
Version:8.10.1 OS:Debian (9.5)
Assigned to: CPU Architecture:x86 (VM 64bits)
Tags: apt repository, apt-key, MySQL, mysql8

[5 Nov 2018 20:48] Austregecilio Cruz Neto
Description:
So, following this: https://dev.mysql.com/doc/mysql-apt-repo-quick-guide/en/ i got the warning

"Warning: apt-key should not be used in scripts (called from postinst maintainerscript of the package mysql-apt-config) on debian"

How to repeat:
Step 1: downloaded the debfile from https://dev.mysql.com/downloads/repo/apt/ and saved it at /tmp

Step 2: Executing the command $ dpkg -i /tmp/mysql-apt-config_0.8.10-1_all.deb, at config screen i just enable mysql8 at first option and press <Ok>

I got the messages
(Reading database ... 31238 files and directories currently installed.)
Preparing to unpack .../mysql-apt-config_0.8.10-1_all.deb ...
Unpacking mysql-apt-config (0.8.10-1) over (0.8.10-1) ...
Setting up mysql-apt-config (0.8.10-1) ...
Warning: apt-key should not be used in scripts (called from postinst maintainerscript of the package mysql-apt-config)
OK
[6 Nov 2018 4:48] Umesh Shastry
Hello Austregecilio,

Thank you for the report.

regards,
Umesh
[6 Nov 2018 9:56] Lars Tangvald
This is a known issue. Only real fix is to drop the execution of apt-key. The user would have to do it manually, and the instructions for doing so could easily be lost in the general apt output. The mysql-apt-config package may need a complete redesign to handle this in a good way.
[6 Nov 2018 12:53] Austregecilio Cruz Neto
Hi Lars,
How could i do the drop of apt-key execution?

Should i use dpkg with some option? Can you detail this?
[17 Jan 8:16] Lars Tangvald
Only real alternative right now is using the manual setup described at https://dev.mysql.com/doc/mysql-apt-repo-quick-guide/en/#repo-qg-apt-repo-manual-setup

The apt_config package essentially just does four things:
* Imports the gpg key (this is the problematic step)
* Identifies your platform (you can get this by running "lsb_release -ics")
* Lets you pick which components to include (mysql-8.0, mysql-tools, mysql-cluster-7.5, etc)
* Writes the listings to /etc/apt/sources.list.d/mysql.list

Closing this bug since it's a duplicate of https://bugs.mysql.com/bug.php?id=85203