Bug #93067 Application Crashes During Model Creation
Submitted: 2 Nov 2018 18:28 Modified: 5 Dec 2018 19:04
Reporter: Travis Moerschbacher Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:8.0.13 OS:Mac OS X (10.14)
Assigned to: CPU Architecture:x86

[2 Nov 2018 18:28] Travis Moerschbacher
Description:
I am working on a model that was previously saved, trying to add a new table and between adding the table name and trying to add the first column the app crashes.

How to repeat:
I have a saved model that loads just fine, but when I try to add a new table the app crashes.

Suggested fix:
????
[3 Nov 2018 1:57] Miguel Solorzano
Thank you for the bug report.
[10 Nov 2018 16:55] Chris Robinson
Any attempt to create a new database from the GUI from scratch will crash upon creating a table and entering a column name.
[13 Nov 2018 10:00] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=93137 marked as duplicate of this one.
[3 Dec 2018 16:56] Roma Chumak
So is there any decision of this problem? Also have the same.
[3 Dec 2018 17:01] Travis Moerschbacher
For what it is worth Roma you can revert to an earlier version.
[5 Dec 2018 19:04] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.14 release, and here's the changelog entry:

A new table added to an existing model caused MySQL Workbench to stop
working.

Thank you for the bug report.