Bug #92957 Unable to drop table more than size 500GB from innodb
Submitted: 26 Oct 2018 8:35 Modified: 26 Oct 2018 10:53
Reporter: kiran nikas Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S3 (Non-critical)
Version:5.6.7 OS:Any
Assigned to: CPU Architecture:Any

[26 Oct 2018 8:35] kiran nikas
Description:
2018-10-26 02:24:53 0x7fdc000b4700  InnoDB: Assertion failure in thread 140582870271744 in file fsp0fsp.cc line 3776
InnoDB: Failing assertion: xdes_get_state(descr, mtr) == XDES_FSEG
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.7/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
06:24:53 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
Attempting to collect some information that could help diagnose the problem.
As this is a crash and something is definitely wrong, the information
collection process might fail.

key_buffer_size=33554432
read_buffer_size=4194304
max_used_connections=1
max_threads=3600
thread_count=2
connection_count=1
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 29572005 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x7fdbb8000ae0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7fdc000b3e70 thread_stack 0x40000
/usr/sbin/mysqld(my_print_stacktrace+0x3b)[0xef7bcb]
/usr/sbin/mysqld(handle_fatal_signal+0x461)[0x7aff11]
/lib64/libpthread.so.0(+0xf5e0)[0x7fe31df515e0]
/lib64/libc.so.6(gsignal+0x37)[0x7fe31c9431f7]
/lib64/libc.so.6(abort+0x148)[0x7fe31c9448e8]
/usr/sbin/mysqld[0x78099c]
/usr/sbin/mysqld[0x1198231]
/usr/sbin/mysqld(_Z14fseg_free_stepPhbP5mtr_t+0x2a4)[0x119b1a4]
/usr/sbin/mysqld[0x10df73d]

How to repeat:
drop the table .
[26 Oct 2018 10:50] Umesh Shastry
Thank you for taking the time to report a problem.  Unfortunately you are not using a current version of the product you reported a problem with -- the problem might already be fixed. Please download a new version from http://www.mysql.com/downloads/

If you are able to reproduce the bug with one of the latest versions, please change the version on this bug report to the version you tested and change the status back to "Open".  Again, thank you for your continued support of MySQL.