Bug #92952 Diagram doesn't show colored icons left to columns for identifying relationships
Submitted: 25 Oct 2018 22:33 Modified: 26 Oct 2018 8:39
Reporter: Karsten Wutzke Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S3 (Non-critical)
Version:8.0.x OS:Any
Assigned to: CPU Architecture:Any

[25 Oct 2018 22:33] Karsten Wutzke
Description:
The new WB 8.0 shows no icons for columns when they are part of an identifying relationship.

Showing no icons is SOO UGLY.

And........ I don't see any benefit in omitting the icons.

DB modeling tends to be somewhat dry, we *need* colors.

PLEASE SEE:

https://pasteboard.co/HK9cKJN.png

How to repeat:
Just have two tables connect via a foreign key that is made an identifying relationship -> reference to PK

Suggested fix:
Either revert to the previous WB versions always showing the colored icons

OR (better):

Make a diagram option (checkbox) like "Hide icons for identifying relationships"
[26 Oct 2018 4:14] Umesh Shastry
Hello Karsten Wutzke,

Thank you for the report and feedback.
Imho this is duplicate of Bug #92141, please see Bug #92141

regards,
Umesh
[26 Oct 2018 8:39] Karsten Wutzke
You are right, this is a dupe.