Bug #92935 Under Schemas, selected object is not visible due to light selection highlight
Submitted: 24 Oct 2018 19:29 Modified: 25 Oct 2018 17:53
Reporter: Harris Kenny Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.3.10 OS:Linux (Pop!_OS 18.10 (Ubuntu-base))
Assigned to: CPU Architecture:x86

[24 Oct 2018 19:29] Harris Kenny
Description:
Actual issue:

When selecting an object, the text is not visible (appears to be white upon selection), seemingly due to highlight/selection color bar not appearing. 

This bug was not evident when running 18.04, but appeared since updating to 18.10.

Bug appears in a variety of GNOME theme selections, including the default Adwaita. 

----

Bug ticket initially submitted to Pop!_OS:

https://github.com/pop-os/gtk-theme/issues/229#issuecomment-432425972

----

More background information:

Distribution:
NAME="Pop!_OS"
VERSION="18.10"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Pop!_OS 18.10"
VERSION_ID="18.10"
HOME_URL="https://system76.com/pop"
SUPPORT_URL="http://support.system76.com"
BUG_REPORT_URL="https://github.com/pop-os/pop/issues"
PRIVACY_POLICY_URL="https://system76.com/privacy"
VERSION_CODENAME=cosmic
UBUNTU_CODENAME=cosmic

Gtk+ 3.0 version:
libgtk-3-0:
Installed: 3.24.1-1ubuntu2
Candidate: 3.24.1-1ubuntu2
Version table:
*** 3.24.1-1ubuntu2 500
500 http://us.archive.ubuntu.com/ubuntu cosmic/main amd64 Packages
100 /var/lib/dpkg/status

Desktop environment:
GNOME

Pop! theme:
Pop!_OS gtk-widgets Theme (The Pop!_GTK Theme) Version 4.0.0

How to repeat:
Open MySQL Workbench, connect to a database, select an object under Schemas.

Suggested fix:
Object selection should be visible to the user. It looks like the highlight selection color is off/non-existent.
[24 Oct 2018 19:30] Harris Kenny
Shown moving selection to another object (fourth from the top) entitled tmp:

Attachment: Screenshot from 2018-10-23 11-59-43.png (image/png, text), 7.76 KiB.

[24 Oct 2018 22:27] Miguel Solorzano
Thank you for the bug report. Please try version 8.0.13. Thanks.
[25 Oct 2018 14:51] Harris Kenny
Miguel,

Appreciate the quick reply. I'd prefer to stick with what's in the repositories, which are running 6.3.10 right now. I am running an Ubuntu-base 18.10 (Cosmic):

https://packages.ubuntu.com/cosmic/mysql-workbench

It looks like upstream Debian Sid is also on 6.3.10:

https://packages.debian.org/sid/mysql-workbench

Do you know when we can expect to see 8.0.13 upstream?

Thank you!
[25 Oct 2018 16:40] Miguel Solorzano
Install Oracle MySQL Package WorkBench

Attachment: 92935_1.png (image/png, text), 128.72 KiB.

[25 Oct 2018 16:42] Miguel Solorzano
Schema Objects

Attachment: 92935.png (image/png, text), 15.03 KiB.

[25 Oct 2018 16:47] Miguel Solorzano
Schemas - Tables

Attachment: 92935_2.png (image/png, text), 13.40 KiB.

[25 Oct 2018 16:50] Miguel Solorzano
Thank you for the feedback. To check bugs is done against the latest released version in this case 8.0.13 which I installed with our package, about the repository you use I don't know when will be available.
[25 Oct 2018 17:53] Harris Kenny
Hi Miguel,

I understand, apologies, I thought I was running the latest version but I see that Debian Sid repository is behind the upstream for the project.

I can confirm I downloaded 8.0.13 in Ubuntu 18.10. The bug is fixed and also 8.0.13 looks very nice. 

If you have a relationship with the Debian maintainers, it would be nice to get 8.0.13 there. Thank you for your help and sorry again!