Bug #9287 Successful build with gcc 3.0 fails make test
Submitted: 18 Mar 2005 20:50 Modified: 28 Apr 2005 7:49
Reporter: Richard Munroe Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:4.1 OS:Linux (Debian Linux 3.0 rc4)
Assigned to: CPU Architecture:Any

[18 Mar 2005 20:50] Richard Munroe
I successfully built a 4.1 MySQL system with GCC 3.0 on my AlphaServer 800 (alphaev56).  When I ran "make test" several of the tests failed.  After building GCC 3.2 and rebuilding MySQL all tests are passed.  Looks like you can't/shouldn't build MySQL on Alpha processors with GCC 3.0.

How to repeat:
I haven't tested the gcc 3.0 failure on other alpha systems, but it failed consistently in the one case I tried.  Simply find an Alphaev56 system, build MySQL with gcc 3.0 and run "make test".

Suggested fix:
Require GCC 3.2 or better (not tested) to build MySQL 4.1.
[28 Apr 2005 7:49] Hartmut Holzgraefe
See the compiler advisory on our download pages:

Compiler Advisory: Several users have reported random crashes and table corruptions when using MySQL binaries compiled with gcc 2.96 on the x86 Linux platform. We suggest that you use gcc 2.95 or gcc 2.91 to compile your own binaries. It should also be safe to use gcc 3.2.