Bug #92860 If ProxyCommand is enabled on ~/.ssh/config "Standard TCP/IP over SSH" not work
Submitted: 19 Oct 2018 9:51 Modified: 20 Oct 2018 0:26
Reporter: Matteo Di Sabatino Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.12 OS:Mac OS X (10.14)
Assigned to: CPU Architecture:x86 (Intel Core i5)

[19 Oct 2018 9:51] Matteo Di Sabatino
Description:
When the option "ProxyCommand" is enabled for a particular domain, MySQL Workbench does not work. When i try to connect, MySQL Workbech send me this error: "Cannot open SSH Tunnel: Socket error: disconnected"

If it could be useful, I've seen that such error was also reported here: https://bugs.mysql.com/bug.php?id=88549 but with a difference version of MySQL Workbench.

How to repeat:
Configure you ~/.ssh/config order to use "ProxyCommand". Example of configuration:

Host *.my.sub.domain
  CheckHostIP no
  ProxyCommand /usr/bin/nc -X connect -x %h:443 %h %p

That try to connect with MySQL Workbench.
[20 Oct 2018 0:26] Miguel Solorzano
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=88549 which was added the version 8.0.12 as product affected.