Bug #92849 MySQL Shell not displaying large results (more than 20 rows) correctly
Submitted: 18 Oct 2018 18:37 Modified: 22 Oct 2018 18:15
Reporter: David Langston Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Shell General / Core Client Severity:S2 (Serious)
Version:8.0.12 OS:Microsoft Windows (win 10)
Assigned to: CPU Architecture:Any

[18 Oct 2018 18:37] David Langston
Description:
MySQL Shell:
whenever I try to execute a select with result set more than 20 rows it won't display past 20 and anytime after that it displays nothing. if I close the shell reopen it works until I hit 20+ rows again

How to repeat:
1.start MySQL shell, connect and use the world sample schema
2.select name from city;

3. all rows don't display
[18 Oct 2018 19:01] Miguel Solorzano
Thank you for the bug report. You could attach a screenshot using here the Files tab using the private option if you wish.
[18 Oct 2018 19:04] David Langston
screen shot

Attachment: bug.JPG (image/jpeg, text), 90.73 KiB.

[18 Oct 2018 19:05] David Langston
I uploaded a screen shot. thx
[18 Oct 2018 20:44] Miguel Solorzano
Running on Laptop - issue repeatable

Attachment: 92849.png (image/png, text), 47.66 KiB.

[18 Oct 2018 20:50] Miguel Solorzano
Running on Desktop - issue non repeatable

Attachment: 92849_2.png (image/png, text), 39.28 KiB.

[18 Oct 2018 20:53] Miguel Solorzano
Thank you for the feedback. I was able to repeat the issue on laptop machine with Windows 10 Pro and not able to repeat when testing on Desktop machine running Windows 10 Pro too. So looks the issue is hardware related.
[18 Oct 2018 20:56] David Langston
screen shot dell xps

Attachment: dell_xps.JPG (image/jpeg, text), 38.82 KiB.

[18 Oct 2018 20:57] David Langston
That's strange. I have fairly new dell xps
[18 Oct 2018 20:58] David Langston
what do you suggest? thx
[18 Oct 2018 21:08] David Langston
I tried the MySQL command line and it works fine on the same laptop where the shell does not. I will try the shell on my Microsoft surface tonight and see if the shell works correctly. thx!
[18 Oct 2018 21:23] Miguel Solorzano
I don't have any guess of that behavior, the machine where I wasn't able to repeat is a DELL XPS 8700 :) and the laptop an LG:
C:\DBS>wmic computersystem get model,name,manufacturer,systemtype
Manufacturer    Model            Name  SystemType
LG Electronics  15Z970-E.BH91P1  URAL  x64-based PC
So the bug is verified and let us our development to analyze the issue.
[18 Oct 2018 23:05] David Langston
hello

just fyi, I downloaded MySQL shell to my Microsoft Surface and it had the same issue of not displaying all rows of data. Looks like it's just not Dell XPS.

thanks
David
[19 Oct 2018 21:02] Krzysztof Grzadziel
Posted by developer:
 
Thank you for your bug report. This issue is already fixed with BUG#28596692 and will be shipped with next MySQL Shell release.

Issue is related to Windows Console, and how it interprets unicode characters encoded in UTF-8 when program print such character byte by byte.
As a workaround you can redirect your output to file.
[19 Oct 2018 21:53] Krzysztof Grzadziel
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.
[22 Oct 2018 14:39] Krzysztof Grzadziel
FYI, new MySQL Shell version is available https://dev.mysql.com/downloads/shell/
Please upgrade to 8.0.13.
[22 Oct 2018 18:15] David Langston
I just confirmed this as fixed. Thank you!