Bug #92847 SSH connection fails if private key path contains Russian characters
Submitted: 18 Oct 2018 17:21 Modified: 5 Dec 2018 17:39
Reporter: Tim Shilov Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:8.0.12 OS:Microsoft Windows (Microsoft Windows 10 Home Single Language)
Assigned to: CPU Architecture:ARM
Tags: regression, WBBugReporter

[18 Oct 2018 17:21] Tim Shilov
Description:
Hello.
Today I updated MySQL Workbench from version 6.3.X to 8.0.12 and all my "TCP/IP over SSH" connections stopped working. They worked before update and I didn't made any changes other than version update.

In the logs I found these messages and nothing more:
20:03:17 [ERR][     SSHSession]: User authentication failed.
20:03:17 [ERR][     SSH tunnel]: Authentication error opening SSH tunnel: Access denied. Authentication that can continue: publickey,gssapi-keyex,gssapi-with-mic

These are not properly describe the problem and I wasted couple of hours searching for solution, generating new SSH keys and etc.

So the problem I found is that if path to private SSH key contains any Russian characters - you get Authentication error. If there's no Russian characters - everything's working.

How to repeat:
1) Put private ssh key into folder with Russian characters in it's path (like 'C:/ключи/').
2) Create new "Standard TCP/IP over SSH" connection in Workbench.
3) Hit "Test Connection".

Suggested fix:
One of these:
1) (Good) Allow Russian characters in file path.
2) (Bad) Give proper error message.
[18 Oct 2018 18:57] Miguel Solorzano
Thank you for the bug report. Issue repeatable only on Windows (tested on Windows 10 Pro) on Ubuntu 18.04 without problems.
[25 Oct 2018 12:45] Marcel Seifert
I get the same error log after the update from 6.3.x to 8.0.13 on Ubuntu 18.10 when:
1) The SSH keyfile is a password protected ed25519 key. It works without a password.
2) The SSH keyfile does not exist.
[29 Nov 2018 20:06] Miguel Tadeu
Posted by developer:
 
commit id: b7f93bb4550247ed3865525f849bf50c9cabd01e
[5 Dec 2018 17:39] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.14 release, and here's the changelog entry:

Characters from Cyrillic character sets when included in the path to SSH
key files caused valid connection attempts to fail without producing a
clear error message.

Thank you for the bug report.
[29 Jan 23:54] BRUNO GASTALDI BGASTALDI
I try in 8.0.14 and not working yet
I use windows 10 pro.
[22 Feb 8:04] aaa aaa
I try in 8.0.15 and not working yet
I use windows 10 pro.
[22 Feb 8:12] aaa aaa
sorry,It's fine in 8.0.15,Win 10 pro.