Bug #92703 Data Export from Local instance, the .sql file is still lower case of REFERENCES
Submitted: 8 Oct 2018 6:34 Modified: 9 Oct 2018 16:57
Reporter: Kevin Zhang Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:8.0.12 OS:Microsoft Windows (Microsoft Windows 10 Home China)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[8 Oct 2018 6:34] Kevin Zhang
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\13901\AppData\Roaming\MySQL\Workbench\log\wb.log]

DROP TABLE IF EXISTS `Course_in_grade`;
/*!40101 SET @saved_cs_client     = @@character_set_client */;
 SET character_set_client = utf8mb4 ;
CREATE TABLE `Course_in_grade` (
  `idCourse_in_grade` int(11) NOT NULL AUTO_INCREMENT,
  `Course_in_gradeName` varchar(45) COLLATE utf8_bin NOT NULL,
  `Course_in_grade_semester` varchar(45) COLLATE utf8_bin DEFAULT NULL COMMENT '',
  `idCourse_in_FK` int(11) NOT NULL,
  `idCourse_in_grade_PubHouse_FK` int(11) NOT NULL,
  `Course_in_gradeNote` varchar(45) COLLATE utf8_bin DEFAULT NULL,
  PRIMARY KEY (`idCourse_in_grade`),
  UNIQUE KEY `idCourse_in_grade_UNIQUE` (`idCourse_in_grade`),
  KEY `idCourse_in_FK_idx` (`idCourse_in_FK`),
  KEY `idCourse_in_grade_PubHouse_FK_idx` (`idCourse_in_grade_PubHouse_FK`),
  CONSTRAINT `idCourse_in_FK` FOREIGN KEY (`idCourse_in_FK`) REFERENCES `course_in` (`idcourse_in`),
  CONSTRAINT `idCourse_in_grade_PubHouse_FK` FOREIGN KEY (`idCourse_in_grade_PubHouse_FK`) REFERENCES `publishing_house` (`idpublishing_house`)
) ENGINE=InnoDB AUTO_INCREMENT=9 DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='';
/*!40101 SET character_set_client = @saved_cs_client */;

I install the MySQL on Windows10 using lower_case_table_name=2, that means I want the Windows using case-sensitive of the table names.
If you use Data Export from Local instance, the .sql file has some problems of the table names like, FOREIGN KEY (`idCourse_in_FK`) REFERENCES `course_in` (`idcourse_in`), the table name `course_in` is still lower case.

How to repeat:
See the Description.
[9 Oct 2018 16:57] Sinisa Milivojevic
HI,

Thank you for your report. However, this is not a bug.

Windows does not have a case sensitive filesystem, which is why lower case table names is always 1 on it, what ever value you put in it.

Value of 2 is reserved for Mac OS, while 0 is available only for Unix systems.

This is all fully explained in our Reference Manual. However, there is one good point here. I think that we should deprecate this variable.

Not a bug.