Bug #92699 Excel tries to sort columns alphabetically before importing data
Submitted: 7 Oct 2018 14:16 Modified: 13 Nov 2018 16:29
Reporter: Kevin Witt Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL for Windows: MySQL for Excel Severity:S2 (Serious)
Version:8.0.12 & 1.3.7 OS:Microsoft Windows (Windows 10 x64)
Assigned to: CPU Architecture:Any (64 bit)
Tags: Excel

[7 Oct 2018 14:16] Kevin Witt
Description:
Using Win10x64 and Excel 2016, when trying to open my tables for editing in Excel it tries to sort the columns alphabetically before importing data, then when it tries to import the data the formats are wrong.

How to repeat:
Create a schema with the columns not in alphabetical order and with different data types

Use excel to populate several rows

Commit the data

Try to open up the editor again
[7 Oct 2018 19:52] Miguel Solorzano
Thank you for the bug report. Please provide the complete test case (create table and way to import data), provide screenshot of the relevant steps. Thanks.
[29 Oct 2018 13:55] Olli Mannisto
I have this same problem. It doesn't appear to matter if the data types are different or not. Or at least the problem does not go away by changing data types back to varchar. 

I'm not sure what you mean by "create a way to import data"? Click "import mysql data" in MySQL for Excel side window?

Attached screenshots and create string.
[29 Oct 2018 13:56] Olli Mannisto
Workbench table view

Attachment: Workbenchview.png (image/png, text), 85.71 KiB.

[29 Oct 2018 13:56] Olli Mannisto
Import preview with alphabetic order column names

Attachment: ImportView.png (image/png, text), 26.30 KiB.

[29 Oct 2018 13:57] Olli Mannisto
Excel worksheet after import with data and column names mismatch

Attachment: ExcelImport.png (image/png, text), 53.47 KiB.

[29 Oct 2018 13:57] Olli Mannisto
Capacitor table script

Attachment: CreateTable.txt (text/plain), 1.16 KiB.

[29 Oct 2018 14:00] Olli Mannisto
Data and columns in synch in workbench

Attachment: Workbench_data.png (image/png, text), 25.32 KiB.

[8 Nov 2018 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[13 Nov 2018 15:21] Miguel Solorzano
https://bugs.mysql.com/bug.php?id=93174 marked as duplicate of this one.
[13 Nov 2018 16:26] Miguel Solorzano
Preview

Attachment: 92699_0.png (image/png, text), 64.78 KiB.

[13 Nov 2018 16:27] Miguel Solorzano
Imported

Attachment: 92699.png (image/png, text), 277.77 KiB.

[13 Nov 2018 16:29] Miguel Solorzano
Thank you for the feedback. Please see prior screenshots added.
[13 Nov 2018 16:36] Olli Mannisto
Are you using Excel 2016?
[13 Nov 2018 17:53] Miguel Solorzano
Excel 2016

Attachment: excel_2016.png (image/png, text), 3.44 KiB.

[14 Nov 2018 15:48] Olli Mannisto
Okay then. There's probably some specific setting in excel/windows we've got different or for example a different locale. Perhaps something prosaic like different MySQL server? Is yours running on linux or windows?

In any case I can't use MySQL excel because it cannot handle INT datatype you can't apparently do autoincrement with varchar. Heidi does my editing needs these days althought proper multi-cell copy/paste would be nice.