Bug #92686 Mysql server 8.0.12 group replication
Submitted: 5 Oct 2018 12:46 Modified: 17 Jan 16:22
Reporter: lionel mazeyrat Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Group Replication Severity:S2 (Serious)
Version:8.0.12 OS:Any
Assigned to: Bogdan Kecman CPU Architecture:Any

[5 Oct 2018 12:46] lionel mazeyrat
Description:
3 Mysql 8.0.12 win server 2016 - GR cluster.
3 nodes are online.

When a restart the service of the R/W node, another go R/W, but the restarted node keep the (MISSING) status.

I've tried to resart it again, the node is still in (MISSING) status.

How to repeat:
3 Mysql 8.0.12 win server 2016 - GR cluster.
3 nodes are online.

When a restart the service of the R/W node, another go R/W, but the restarted node keep the (MISSING) status.

I've tried to resart it again, the node is still in (MISSING) status.
[11 Oct 2018 12:31] Bogdan Kecman
Hi,
I need to see your config files, how exactly did you setup the cluster on windows.

all best
Bogdan
[12 Oct 2018 13:13] lionel mazeyrat
my.ini server 1

Attachment: my1.ini (application/octet-stream, text), 13.80 KiB.

[12 Oct 2018 13:13] lionel mazeyrat
my.ini server 2

Attachment: my2.ini (application/octet-stream, text), 13.78 KiB.

[12 Oct 2018 13:13] lionel mazeyrat
my.

Attachment: my3.ini (application/octet-stream, text), 13.77 KiB.

[12 Oct 2018 13:14] lionel mazeyrat
my.ini server 3

Attachment: my3.ini (application/octet-stream, text), 13.77 KiB.

[21 Dec 2018 7:50] Bogdan Kecman
Hi,

I'm testing this on Windows and on Linux with 8.0.13 and I cannot reproduce the issue you are referring to. In what way you "restart service" on these boxes? 

Thanks
Bogdan
[21 Dec 2018 8:03] lionel mazeyrat
thanks
I will upgrade to 8.0.13 as soon as possible and test again.
[21 Dec 2018 8:11] Bogdan Kecman
Hi,

Thanks for retesting with 8.0.13, now I don't see anything in the release info that suggest anything relevant to this issue is changed there but still.. In the meantime please let me know the answer to "how do you exactly restart the service" so I can retest on my end again.

thanks
Bogdan
[21 Dec 2018 12:18] lionel mazeyrat
The mysql service was restarted from the windows services control pop-up with a stop and then start command.
[21 Dec 2018 12:18] lionel mazeyrat
The mysql service was restarted from the windows services control pop-up with a stop and then start command.
[26 Dec 2018 8:11] WANG GUANGYOU
check your configuration file. I have not found the group_replication related configuration
[17 Jan 16:22] Bogdan Kecman
Hi,
Sorry for the late reply, I was unavailable for a while there.

The config files does not correlate with your report. With normal replication this makes no sense, with group replication - regular config I can't reproduce your problem, so I assume this is "configuration" issue that you should solve by contacting support team.

I'm closing as not-a-bug for now but if you can provide a reproducible test case showing this is a bug please feel free to reopen or create a new one.

Best regards
Bogdan