Bug #92343 SIGABRT while executing query
Submitted: 7 Sep 2018 21:09 Modified: 7 Sep 2018 21:21
Reporter: d takken Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: DML Severity:S2 (Serious)
Version:8.0.11 OS:Linux
Assigned to: CPU Architecture:x86

[7 Sep 2018 21:09] d takken
Description:
mysql stderr | 2018-09-07T19:13:19.114723Z 0 [Warning] [MY-010915] [Server] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release.
2018-09-07T19:13:19.118989Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.11) starting as process 22
mysql stderr | mbind: Operation not permitted
mbind: Operation not permitted
mbind: Operation not permitted
mbind: Operation not permitted
mysql stderr | 2018-09-07T19:13:20.046641Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
mysql stderr | mbind: Operation not permitted
mysql stderr | mbind: Operation not permitted
mysql stderr | mbind: Operation not permitted
mysql stderr | TRANSACTION 421797033163512, ACTIVE 0 sec starting index read
mysql tables in use 6, locked 0
0 lock struct(s), heap size 1136, 0 row lock(s)
MySQL thread id 614, OS thread handle 140321884137216, query id 1875 10.0.0.11 root Opening tables
SELECT *,
                `TABLE_SCHEMA`       AS `Db`,
                `TABLE_NAME`         AS `Name`,
                `TABLE_TYPE`         AS `TABLE_TYPE`,
                `ENGINE`             AS `Engine`,
                `ENGINE`             AS `Type`,
                `VERSION`            AS `Version`,
                `ROW_FORMAT`         AS `Row_format`,
                `TABLE_ROWS`         AS `Rows`,
                `AVG_ROW_LENGTH`     AS `Avg_row_length`,
                `DATA_LENGTH`        AS `Data_length`,
                `MAX_DATA_LENGTH`    AS `Max_data_length`,
                `IN

InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/8.0/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
mysql stderr | 19:17:42 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
Attempting to collect some information that could help diagnose the problem.
As this is a crash and something is definitely wrong, the information
collection process might fail.

key_buffer_size=33554432
read_buffer_size=131072
max_used_connections=5
max_threads=500
thread_count=3
connection_count=2
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 230283 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x7f9ec0018c10
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
mysql stderr | stack_bottom = 7f9f3c0edc70 thread_stack 0x46000
mysql stderr | /usr/sbin/mysqld(my_print_stacktrace(unsigned char*, unsigned long)+0x3d) [0x1a83add]
/usr/sbin/mysqld(handle_fatal_signal+0x423) [0xcd8813]
/lib64/libpthread.so.0(+0xf6d0) [0x7f9f5ded36d0]
/lib64/libc.so.6(gsignal+0x37) [0x7f9f5c1ea277]
/lib64/libc.so.6(abort+0x148) [0x7f9f5c1eb968]
/usr/sbin/mysqld() [0xac64b0]
/usr/sbin/mysqld(row_search_mvcc(unsigned char*, page_cur_mode_t, row_prebuilt_t*, unsigned long, unsigned long)+0x31d8) [0x1c9c2d8]
/usr/sbin/mysqld(ha_innobase::index_read(unsigned char*, unsigned char const*, unsigned int, ha_rkey_function)+0x29e) [0x1b640be]
/usr/sbin/mysqld(ha_innobase::rnd_pos(unsigned char*, unsigned char*)+0x59) [0x1b4bc29]
/usr/sbin/mysqld(handler::ha_rnd_pos(unsigned char*, unsigned char*)+0x1c4) [0xdc9e24]
/usr/sbin/mysqld() [0xb3f3b3]
/usr/sbin/mysqld(sub_select(JOIN*, QEP_TAB*, bool)+0x2e7) [0xba2217]
/usr/sbin/mysqld(JOIN::exec()+0x410) [0xba0f90]
/usr/sbin/mysqld(Sql_cmd_dml::execute_inner(THD*)+0x104) [0xc16674]
/usr/sbin/mysqld(Sql_cmd_dml::execute(THD*)+0x147) [0xc1eb07]
/usr/sbin/mysqld(mysql_execute_command(THD*, bool)+0x18ad) [0xbd140d]
/usr/sbin/mysqld(mysql_parse(THD*, Parser_state*)+0x33b) [0xbd594b]
/usr/sbin/mysqld(dispatch_command(THD*, COM_DATA const*, enum_server_command)+0x2cc7) [0xbd8877]
/usr/sbin/mysqld(do_command(THD*)+0x1a1) [0xbd9351]
/usr/sbin/mysqld() [0xccb5a0]
/usr/sbin/mysqld() [0x1f13e2f]
/lib64/libpthread.so.0(+0x7e25) [0x7f9f5decbe25]
/lib64/libc.so.6(clone+0x6d) [0x7f9f5c2b2bad]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (7f9ec00008e8):  mysql stderr | SELECT *,                 `TABLE_SCHEMA`       AS `Db`,                 `TABLE_NAME`         AS `Name`,                 `TABLE_TYPE`         AS `TABLE_TYPE`,                 `ENGINE`             AS `Engine`,                 `ENGINE`             AS `Type`,                 `VERSION`            AS `Version`,                 `ROW_FORMAT`         AS `Row_format`,                 `TABLE_ROWS`         AS `Rows`,                 `AVG_ROW_LENGTH`     AS `Avg_row_length`,                 `DATA_LENGTH`        AS `Data_length`,                 `MAX_DATA_LENGTH`    AS `Max_data_length`,                 `INDEX_LENGTH`       AS `Index_length`,                 `DATA_FREE`          AS `Data_free`,                 `AUTO_INCREMENT`     AS `Auto_increment`,  mysql stderr |                 `CREATE_TIME`        AS `Create_time`,                 `UPDATE_TIME`        AS `Update_time`,                 `CHECK_TIME`         AS `Check_time`,                 `TABLE_COLLATION`    AS `Collation`,                 `CHECKSUM`           AS `Checksum`,        
Connection ID (thread ID): 614
Status: NOT_KILLED

The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.

How to repeat:
This happened just once, I could not reproduce it.
[7 Sep 2018 21:21] Miguel Solorzano
Not enough information was provided for us to be able to handle this bug. Please re-read the instructions at http://bugs.mysql.com/how-to-report.php

If you can provide more information, feel free to add it to this bug with the repeatable test case, try the latest version 8.0.12 also.

Thank you for your interest in MySQL.