Bug #9220 Connection Timout problem...
Submitted: 16 Mar 2005 13:02 Modified: 24 Apr 2005 22:12
Reporter: Sven Betzold Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:1.0.4 OS:Microsoft Windows (W2K3)
Assigned to: Reggie Burnett CPU Architecture:Any

[16 Mar 2005 13:02] Sven Betzold
Description:
- OS: W2K3
- MySQL-Server: 4.1.10

As long as I'm using something like a "simple" connection string

-> "server=1.1.1.1;user id=bogus;pwd=bogus;connection timeout=5;pooling=false"

everything works fine. The IP does not exists - so after 5 seconds we will get a timeout.

BUT - as soon as I use a "port" statement within the connection string

-> "server=1.1.1.1;port=3315;user id=bogus;pwd=bogus;connection timeout=5;pooling=false"

(and we have to so, because our MySQL installations are NOT running on the default port) - the timeout does not work anymore and the MySQL.Data.dll comes back with an execption ("Connection unexpectedly terminated").

And actually we want to work with something like this...:

"server=1.1.1.1;port=3315;user id=bogus;pwd=bogus;connection timeout=5;use compression=true;pooling=true;min pool size=5;max pool size=100;

How to repeat:
Just use a connection string with a port statement and a wrong IPAdress - i.e. "1.1.1.1"...
[24 Apr 2005 22:12] Jorge del Conde
Hi!

Can you please give us a test-case that reproduces this behaviour ?

I was unable to reproduce your bug-report.

Thanks