Bug #92015 Autocomplete Data Not Automatically Loading
Submitted: 14 Aug 2018 18:58 Modified: 14 Sep 2018 12:15
Reporter: Ryan Taylor Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:8.0.12, 8.0.17 OS:Microsoft Windows (Microsoft Windows 7 Professional Service Pack 1)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[14 Aug 2018 18:58] Ryan Taylor
Description:
Autocomplete will load database names, but once a database is written in query, it will not show table names. Once a table is written, the column names do not appear in autocomplete box either.

How to repeat:
In query window type: "SELECT * FROM " then hit ctrl+space to bring up autocomplete dialog box... hit enter to write a database name to screen.
type: "." hit ctrl+space to bring up autocomplete dialog box, but no box appears.

Suggested fix:
It worked in previous version (6.3.9)
[14 Aug 2018 19:31] Ryan Taylor
Forgot to mention that if you have each schema open (dropped down) in the Navigator, the autocomplete will work, that is my current workaround, but then I have to manually open for each connection.
[14 Aug 2018 21:23] MySQL Verification Team
Thank you for the bug report. Noticed on Windows 10 Pro too.
[23 Aug 2018 8:00] Mike Lischke
Posted by developer:
 
This behavior is by design as people might work over slow internet connections or may have large schemas with many objects. For the same reasons we also don't load the entire schema tree upfront, but only when you expand a schema node (or make a schema the default). In fact both these events are now directly coupled. The auto completion symbol table is filled with object names only when a schema is loaded.

We may consider a setting that forces to load all schemas on opening a connection, if the user wants that, but I doubt this will please anyone, since this usually puts some heavy load on the server on each connection start (unless you have only a small server, with only a few small schemas).
[13 Sep 2018 18:37] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=92410 marked as duplicate of this one.
[14 Sep 2018 10:24] Mauro Molinari
>This behavior is by design 

By design??? How can you say that this is by design, if you say you have "code-completion" but code-completion actually isn't able to retrieve the column names of a table in a super-simple SELECT statement? 

It was working fine (with absolutely no performance issue, even with thousands of schemas in the DBMS instance) in 6.3.10...

Also, I can't reproduce the workaround. If I have the following path expanded in the Schemas Navigator:

myschema (bold, i.e. default one) -> Tables -> MY_TABLE -> Columns

and I type the following in the editor:
SELECT * FROM MY_TABLE where |
and I invoke code assist at "|", I get no suggestions at all for MY_TABLE columns.
[14 Sep 2018 12:15] Ryan Taylor
I should have been clearer in the workaround statement. You are correct, it still does not produce column names. It will however allow auto-complete to pick up table names within the schema.
[23 Oct 2018 6:32] Davis S
This is still unresolved in 8.0.13, Win10 Pro. Autocomplete works fine in the SELECT FROM portion, but not in the WHERE section. "WHERE t." offers nothing. Of course, if I type out the full table name "transactions." autocomplete works fine.
The last version where this worked for me was 6.3.10.

"SELECT t.transaction_id from transactions t
WHERE t."
[23 Oct 2018 7:18] Mauro Molinari
I would like to stress the fact that (at least in 8.0.12) autocompletion is NOT working properly in the FROM clause either.

This, together with the fact that maintainers decided to drop support for MySQL Server 5.5 in a minor 8.0.13 release, will force us to find some other solution.
I would like to highlight that MySQL 5.5 should be supported until December 2018 and is still supported in many Linux distributions that will be EOL in April 2019. I don't think it's fair to drop support for it in a minor MySQL Workbench release containing many other bug fixes and regression fixes that will be useful for anybody and won't impact backward compatibility...
[7 Jan 2019 1:25] Sung Michelle
I’m currently on Mac Mojave(10.14.2) using mysql workbench(8.0.13).  I find the auto completion module have the same issue.

It can pop out prompts(table hints) for code like “select * from …”, it can also make prompts(column hints) for code like “select a.  from table_xxx as a” .
However, it would fail for column hints if I try “select * from table_xxx as a inner join table_yyy as b on a.”, or the same failure menetioned by other users when use in "where" statement.
[28 Jan 2019 10:25] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=94094 marked as duplicate of this one.
[29 Jan 2019 16:11] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=94119 marked as duplicate of this one.
[9 Apr 2019 20:09] Jenny Nunemacher
This seems like the same problem I am experiencing, however, I only recently started to experience it in the last month or so. I downgraded back to vs 6.0.10 and it still isn't working. Extremely frustrating. I am using MacOS Mojave.
[27 Sep 2019 4:03] Richard Duy Dang
Autocomplete just does not fill in the Field names for Update statements.
[14 Nov 2019 5:48] MySQL Verification Team
Bug #97162 Marked as duplicate of this one.
[28 Nov 2019 7:15] MySQL Verification Team
Bug #97782 marked as duplicate of this one.
[8 Feb 2020 12:12] Andrew McDougall
I think hanging issue (which for me [8.0.19, W10] makes it impossible to use the editor past the FROM statement unless autocomplete is turned off) is more than just data not loading. I don't think bugs #92410, #94094 & #94119 should have been marked as duplicate to this: it is a significant bug and its severity should upped.
[14 Mar 13:36] Michael Tyler
Folks this needs to be upgraded in severity since it is resulting in unrecoverable hanging.