Bug #91992 I cant grant privileges for the information_schema to a user
Submitted: 13 Aug 2018 10:38 Modified: 13 Aug 2018 17:16
Reporter: Julio T Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Information schema Severity:S2 (Serious)
Version:8.0.12 OS:Microsoft Windows (Microsoft Windows 10 Home)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[13 Aug 2018 10:38] Julio T
Description:
----[For better reports, please attach the log file after submitting. You can find it in C:\Users\Julio\AppData\Roaming\MySQL\Workbench\log\wb.log]

I cant grant privileges for the information_schema to a user and this cause a serius problem while using Visual Studio 2017 

How to repeat:
Try to grant a information_schema privilege to a user (for example root)
[13 Aug 2018 10:53] Julio T
log for the error

Attachment: wb.log (application/octet-stream, text), 12.65 KiB.

[13 Aug 2018 17:16] Miguel Solorzano
Thank you for the bug report. Duplicate of https://bugs.mysql.com/bug.php?id=45430
[13 Aug 2018 17:21] Miguel Solorzano
See: https://dev.mysql.com/doc/refman/8.0/en/information-schema-introduction.html

"INFORMATION_SCHEMA and Privileges

Each MySQL user has the right to access these tables, but can see only the rows in the tables that correspond to objects for which the user has the proper access privileges. In some cases (for example, the ROUTINE_DEFINITION column in the INFORMATION_SCHEMA ROUTINES table), users who have insufficient privileges see NULL. These restrictions do not apply for InnoDB tables; you can see them with only the PROCESS privilege. "