Bug #91957 Automatic de-selection of last executed command
Submitted: 10 Aug 2018 7:21 Modified: 10 Aug 2018 7:32
Reporter: Pietro Minicelli Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.3.8 OS:Microsoft Windows (Microsoft Windows 7 Professional Service Pack 1)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[10 Aug 2018 7:21] Pietro Minicelli
Description:
First of all I apologize for my bad english.

In previous versions (certainly in version 5.3) after executing a command the portion of text of the executed command remained selected, so you could continue executing the selected command only by clicking on the lighting icon.

This morning I had this bad experience with version 6.3: some moments after executing a selected command I needed to execute it again, but since I was used to work on version 5.3, I didn't notice that after executing the command there was no text selected, therefore the SQL editor executed ALL of the commands contained in the editor (insert... update...)!!!

I think that the right behaviour was the one of version 5.3, if you select a portion of text and you want to execute it there's no reason to de-select it after execution, or am I wrong?

How to repeat:
In version 5.3: select a portion of text in the SQL editor and execute it; after execution the text remained selected.

In version 6.3: select a portion of text in the SQL editor and execute it; afeter execution no text is selected.

Suggested fix:
After executing commands the selection remains unchanged.
[10 Aug 2018 7:32] Umesh Shastry
Hello Pietro,

Thank you for the report.
Could you please upgrade WB to latest GA MySQL Workbench 8.0.12? I have checked both MySQL Workbench 6.3.8 and MySQL Workbench 8.0.12 and I can confirm you that issue is not there in latest GA.

Thanks,
Umesh