Bug #91940 MySQL 5.7.17 abnormal crash
Submitted: 9 Aug 2018 2:31 Modified: 16 Aug 2018 12:27
Reporter: chen xiaokang Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:5.7.17 OS:CentOS (Linux 3.10.0-229.el7.x86_64)
Assigned to: CPU Architecture:Any
Tags: MySQL 5.7.17 abnormal crash

[9 Aug 2018 2:31] chen xiaokang
Description:
MySQL 5.7.17 abnormal crash

I did not find obvious errors,just crash 

Maybe it's an unknown problem ?

mysqld error log As shown below:
####################################################################################
2018-08-08T23:41:20.266556+08:00 2009811 [Note] Aborted connection 2009811 to : 'abs' user: 'absapp' host: '192.168.2.172' (Got an error reading communication packets)
2018-08-09T00:05:36.611101+08:00 2006927 [Warning] Timeout waiting for reply of binlog (file: mysql_bin.000474, pos: 712008094), semi-sync up to file mysql_bin.000474, position 667397154.
....
2018-08-09T00:06:30.010736+08:00 2013642 [Warning] Timeout waiting for reply of binlog (file: mysql_bin.000474, pos: 1044252398), semi-sync up to file mysql_bin.000474, position 1024772376.
2018-08-09T00:06:30.010757+08:00 2013642 [Note] Semi-sync replication switched OFF.
2018-08-09T00:06:30.158592+08:00 0 [Note] Semi-sync replication switched ON at (mysql_bin.000474, 1044252398)
2018-08-09T00:15:04.988574+08:00 2007454 [Note] Aborted connection 2007454 to : 'abs' user: 'absapp' host: '192.168.2.162' (Got an error reading communication packets)
2018-08-09T00:22:22.183248+08:00 2006605 [Note] Aborted connection 2006605 to : 'abs' user: 'absapp' host: '192.168.2.172' (Got an error reading communication packets)

 '192.168.2.172' (Got an error reading communication packets)
2018-08-09T02:09:14.080650+08:00 1962902 [Note] Aborted connection 1962902 to : 'idm' user: 'idm' host: '192.168.2.172' (Got an error reading communication packets)
2018-08-09T02:09:14.080642+08:00 1962896 [Note] Aborted connection 1962896 to : 'idm' user: 'idm' host: '192.168.2.172' (Got an error reading communication packets)
2018-08-09T02:09:14.132448+08:00 0 [Note] Giving 972 client threads a chance to die gracefully
2018-08-09T02:09:14.149148+08:00 0 [Note] Shutting down slave threads
2018-08-09T02:09:14.149237+08:00 797 [Note] Error reading relay log event for channel '': slave SQL thread was killed
2018-08-09T02:09:14.215658+08:00 796 [Note] Slave I/O thread killed while reading event for channel ''
2018-08-09T02:09:14.215693+08:00 796 [Note] Slave I/O thread exiting for channel '', read up to log 'mysql_bin.000474', position 338844775
2018-08-09T02:09:22.234964+08:00 943 [Note] Stop semi-sync binlog_dump to slave (server_id: 10)
2018-08-09T02:09:22.761176+08:00 943 [Note] Semi-sync replication switched OFF.
2018-08-09T02:09:24.235010+08:00 0 [Note] Forcefully disconnecting 899 remaining clients
2018-08-09T02:09:24.235083+08:00 0 [Warning] ./bin/mysqld: Forcing close of thread 2012984  user: 'mysql'

2018-08-09T02:09:24.235100+08:00 0 [Warning] ./bin/mysqld: Forcing close of thread 2011034  user: 'mysql'
...........................

2018-08-09T02:09:24.255628+08:00 0 [Warning] ./bin/mysqld: Forcing close of thread 1963769  user: 'idm'

2018-08-09T02:09:24.255652+08:00 0 [Note] Event Scheduler: Purging the queue. 0 events
2018-08-09T02:09:24.308148+08:00 0 [Note] Binlog end
2018-08-09T02:09:24.486319+08:00 0 [Note] Shutting down plugin 'rpl_semi_sync_slave'
2018-08-09T02:09:24.486352+08:00 0 [Note] Shutting down plugin 'rpl_semi_sync_master'
2018-08-09T02:09:24.486370+08:00 0 [Note] Stopping ack receiver thread
2018-08-09T02:09:24.496941+08:00 0 [Note] unregister_replicator OK
2018-08-09T02:09:24.496956+08:00 0 [Note] Shutting down plugin 'ngram'
2018-08-09T02:09:24.496961+08:00 0 [Note] Shutting down plugin 'ARCHIVE'
2018-08-09T02:09:24.496965+08:00 0 [Note] Shutting down plugin 'partition'
2018-08-09T02:09:24.496968+08:00 0 [Note] Shutting down plugin 'BLACKHOLE'
2018-08-09T02:09:24.496975+08:00 0 [Note] Shutting down plugin 'CSV'
2018-08-09T02:09:24.496980+08:00 0 [Note] Shutting down plugin 'MEMORY'
......
2018-08-09T02:09:24.497114+08:00 0 [Note] Shutting down plugin 'Inno'
2018-08-09T02:09:24.510791+08:00 0 [Note] Inno: FTS optimize thread exiting.
2018-08-09T02:09:24.519576+08:00 0 [Note] Inno: Starting shutdown...
2018-08-09T02:09:24.619806+08:00 0 [Note] Inno: Dumping buffer pool(s) to /mysqldata/3339/ib_buffer_pool
2018-08-09T02:09:24.949678+08:00 0 [Note] Inno: Buffer pool(s) dump completed at 180809  2:09:24
2018-08-09T02:09:32.647624+08:00 0 [Note] Inno: Shutdown completed; log sequence number 1589364374198
2018-08-09T02:09:35.563693+08:00 0 [Note] Inno: Removed temporary tablespace data file: "ibtmp1"
2018-08-09T02:09:35.563740+08:00 0 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
2018-08-09T02:09:35.563792+08:00 0 [Note] Shutting down plugin 'MyISAM'
2018-08-09T02:09:35.563816+08:00 0 [Note] Shutting down plugin 'sha256_password'
2018-08-09T02:09:35.563821+08:00 0 [Note] Shutting down plugin 'mysql_native_password'
2018-08-09T02:09:35.578997+08:00 0 [Note] Shutting down plugin 'binlog'
2018-08-09T02:09:35.609239+08:00 0 [Note] ./bin/mysqld: Shutdown complete

2018-08-08T18:09:36.216282Z mysqld_safe mysqld from pid file /mysqldata/3339/mysql.pid ended

####################################################################################

How to repeat:
Unknown

Suggested fix:
Unknown
[16 Aug 2018 12:27] Sinisa Milivojevic
Hi,

Your error log shows clearly that there is no crash what so ever. What you had is orderly and normal shutdown process. No crashes what so ever ...

It seems that it occurs due to the badly configured semi-sync replication. You have to fix that and there will be no further shutdowns.