Bug #91917 InnoDB: about forcing recovery. 06:14:17 UTC - mysqld got signal 6 ;
Submitted: 7 Aug 2018 10:42 Modified: 7 Aug 2018 11:52
Reporter: Anil Kumar Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:mysqld 5.7.21 OS:SUSE
Assigned to: CPU Architecture:x86

[7 Aug 2018 10:42] Anil Kumar
Description:
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
Attempting to collect some information that could help diagnose the problem.
As this is a crash and something is definitely wrong, the information
collection process might fail.

key_buffer_size=8388608
read_buffer_size=131072
max_used_connections=0
max_threads=5000
thread_count=0
connection_count=0
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 1994988 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x40000
/usr/sbin/mysqld(my_print_stacktrace+0x2c)[0xf1311c]
/usr/sbin/mysqld(handle_fatal_signal+0x451)[0x7f6e11]
/lib64/libpthread.so.0(+0xf850)[0x7fa5f1190850]
/lib64/libc.so.6(gsignal+0x35)[0x7fa5efc4a885]
/lib64/libc.so.6(abort+0x181)[0x7fa5efc4be61]
/usr/sbin/mysqld[0x7c78fa]
/usr/sbin/mysqld(_Z25page_cur_parse_insert_recmPKhS0_P11buf_block_tP12dict_index_tP5mtr_t+0xc38)[0x10972c8]
/usr/sbin/mysqld[0x106f075]
/usr/sbin/mysqld(_Z22recv_recover_page_funcmP11buf_block_t+0x9ee)[0x106fcde]
/usr/sbin/mysqld(_Z20buf_page_io_completeP10buf_page_tb+0x41d)[0x11df7dd]
/usr/sbin/mysqld(_Z12fil_aio_waitm+0x13f)[0x125651f]
/usr/sbin/mysqld(io_handler_thread+0x88)[0x113e768]
/lib64/libpthread.so.0(+0x7806)[0x7fa5f1188806]
/lib64/libc.so.6(clone+0x6d)[0x7fa5efcf664d]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
2018-08-07T06:20:33.586980Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-08-07T06:20:33.588113Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.21) starting as process 8624 ...
2018-08-07T06:20:33.590936Z 0 [Note] InnoDB: PUNCH HOLE support available
2018-08-07T06:20:33.590957Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2018-08-07T06:20:33.590961Z 0 [Note] InnoDB: Uses event mutexes
2018-08-07T06:20:33.590966Z 0 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
2018-08-07T06:20:33.590969Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.3
2018-08-07T06:20:33.590972Z 0 [Note] InnoDB: Using Linux native AIO
2018-08-07T06:20:33.592174Z 0 [Note] InnoDB: Number of pools: 1
2018-08-07T06:20:33.592271Z 0 [Note] InnoDB: Using CPU crc32 instructions
2018-08-07T06:20:33.593289Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2018-08-07T06:20:33.599418Z 0 [Note] InnoDB: Completed initialization of buffer pool
2018-08-07T06:20:33.600873Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2018-08-07T06:20:33.612897Z 0 [Note] InnoDB: Highest supported file format is Barracuda.
2018-08-07T06:20:33.614293Z 0 [Note] InnoDB: Log scan progressed past the checkpoint lsn 2194568942505
2018-08-07T06:20:33.622449Z 0 [Note] InnoDB: Doing recovery: scanned up to log sequence number 2194569224130
2018-08-07T06:20:33.623249Z 0 [Note] InnoDB: Database was not shutdown normally!
2018-08-07T06:20:33.623254Z 0 [Note] InnoDB: Starting crash recovery.
2018-08-07T06:20:33.645082Z 0 [Note] InnoDB: 2 transaction(s) which must be rolled back or cleaned up in total 413 row operations to undo
2018-08-07T06:20:33.645103Z 0 [Note] InnoDB: Trx id counter is 1844224
2018-08-07T06:20:33.645111Z 0 [Note] InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percent: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 2018-08-07 11:50:33 0x7fc72bb35700  InnoDB: Assertion failure in thread 140493408392960 in file page0cur.cc line 1305
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.7/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.

How to repeat:
After rebooting the Server it is appearing the same
[7 Aug 2018 10:47] Anil Kumar
Please find attached error since the issue is occuring

Attachment: MYSQLERROR.log.docx (application/vnd.openxmlformats-officedocument.wordprocessingml.document, text), 21.04 KiB.

[7 Aug 2018 11:52] Miguel Solorzano
Thank you for taking the time to report a problem.  Unfortunately you
are not using a current version of the product you reported a problem
with -- the problem might already be fixed. Please download
a new version from http://www.mysql.com/downloads/.

Also, there is no test case provided in the bug report and hence there
is nothing we can verify here.  If you are able to reproduce the bug
with one of the latest versions, please attach the exact reproducible
test case and change the version on this bug report to the version you
tested.  Again, thank you for your continued support of MySQL.