Bug #91876 PREPARED statement fails for SET RESOURCE GROUP
Submitted: 2 Aug 2018 17:52 Modified: 10 Oct 2018 18:34
Reporter: Kedar Vaijanapurkar Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Prepared statements Severity:S3 (Non-critical)
Version:8, 8.0.12 OS:Any
Assigned to: CPU Architecture:Any
Tags: prepared, resource group

[2 Aug 2018 17:52] Kedar Vaijanapurkar
Description:
As per PREPARED statement doc, SET command is allowed though that doesn't work for "SET RESOURCE GROUP" and generates following error:

ERROR 1295 (HY000): This command is not supported in the prepared statement protocol yet

Ref: 
https://dev.mysql.com/doc/refman/8.0/en/resource-groups.html
https://dev.mysql.com/doc/refman/8.0/en/sql-syntax-prepared-statements.html
https://www.db-fiddle.com/f/upt1a2oRb6foH8Xe88ZCzR/0

How to repeat:
Hit Run: https://www.db-fiddle.com/f/upt1a2oRb6foH8Xe88ZCzR/0

Suggested fix:
Mention in documentation until the issue is resolved.
[3 Aug 2018 5:20] Umesh Shastry
Hello Kedar,

Thank you for the report!

regards,
Umesh
[10 Oct 2018 18:34] Paul Dubois
Posted by developer:
 
Fixed in 8.0.14.

SET RESOURCE GROUP could not be executed as a prepared statement.