Bug #91836 Password management broken for those who don't use gnome-keyring
Submitted: 30 Jul 2018 22:20 Modified: 3 Aug 2018 11:50
Reporter: Ryan Rankin Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:MySQL Workbench CE (GPL) 8.0.12 CE build OS:Linux (Antergos (KDE Plasma))
Assigned to: CPU Architecture:x86
Tags: gnome-keyring, libsecret, org.freedesktop.secrets, password

[30 Jul 2018 22:20] Ryan Rankin
Description:
I am a KDE Plasma user. I do not use gnome-keyring and never did.  I do have libsecret installed.

However, since the deprecation of libgnome-keyring and replacement with libsecret, I cannot read, write or clear passwords therefore I cannot connect anywhere and the product is unusable.

When trying to connect to a host, I get the following error:

"Exception caught when trying to find a password for '<hostname>' connection: The name org.freedesktop.secrets was not provided by any .service files"

Attempting to and store a new password in the keychain produces a similar error:

"Could not store password The name org.freedesktop.secrets was not provided by any .service files"

Attempting to clear the password in the keychain produces a similar error:

"Could not clear password: forget_password The name org.freedesktop.secrets was not provided by any .service files"

How to repeat:
1. uninstall/do not install gnome-keyring
2. try to connect to any host using standard tcp/ip over ssh
[3 Aug 2018 11:50] Miguel Tadeu
Hi,
apparently KDE has not a frontend for libsecret yet. As soon as KDE upgrades kwallet or creates a new frontend, it will be supported out of the box. Until then, the easiest solution is to use gnome-keyring.
[24 Aug 2018 21:37] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=92183 marked as duplicate of this one.
[10 Apr 2019 22:48] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=94975 marked as duplicate of this one.
[11 Apr 2019 14:05] Stephen McCants
In my experience, gnome-keyring is buggy and causes more problems than it solves. 
 So, actually, the easiest work around is to use something like DBeaver instead of MySQL Workbench.